SDNU 1094.Clock 时针分针角度


1094.Clock
Time Limit: 1000 MS    Memory Limit: 32768 KB

Description
There is an analog clock with two hands: an hour hand and a minute hand. The two hands form an angle. The angle is measured as the smallest angle between the two hands. The angle between the two hands has a measure that is greater than or equal to 0 and less than or equal to 180 degrees.
Given a sequence of five distinct times written in the format hh : mm , where hh are two digits representing full hours (00 <= hh <= 23) and mm are two digits representing minutes (00 <= mm <= 59) , you are to write a program that finds the median, that is, the third element of the sorted sequence of times in a nondecreasing order of their associated angles. Ties are broken in such a way that an earlier time precedes a later time.

For example, suppose you are given a sequence (06:05, 07:10, 03:00, 21:00, 12:55) of times. Because the sorted sequence is (12:55, 03:00, 21:00, 06:05, 07:10), you are to report 21:00.


Input

The input consists of T test cases. The number of test cases (T) is given on the first line of the input file. Each test case is given on a single line, which contains a sequence of five distinct times, where times are given in the format hh : mm and are separated by a single space.


Output

Print exactly one line for each test case. The line is to contain the median in the format hh : mm of the times given. The following shows sample input and output for three test cases.


Sample Input

3
00:00 01:00 02:00 03:00 04:00
06:05 07:10 03:00 21:00 12:55
11:05 12:05 13:05 14:05 15:05

Sample Output

02:00
21:00
14:05

    题意是说给出5个时间,然后计算在这5个时间的时候,时针与分针的夹角,按照夹角的大小排序之后,输出中间的那个时间(如果两个夹角相同则时间小的排在前面)。一开始小看这个题了,觉得不会考虑那么麻烦把细微的转动也算上,所以全按正好停在整点算的,结果就是WA...好吧时间转动的夹角也是要算的。

    下面AC代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

struct tim
{
    char s[10];
    int k;
    int dis;
};

tim t[10];

int cmp(tim x,tim y)
{
    if(x.dis!=y.dis)
        return x.dis<y.dis;
    return x.k<y.k;
}

int main()
{
    int T;
    int a,b;
    int i;
    scanf("%d",&T);
    while(T--)
    {
        memset(t,0,sizeof(t));
        for(i=0;i<5;i++)
        {
            scanf("%s",t[i].s);
            t[i].k=a=atoi(t[i].s);
            b=(t[i].s[3]-'0')*10+(t[i].s[4]-'0');
            //cout<<i<<" "<<a<<" "<<b<<endl;
            if(a>12)
                t[i].dis=abs((a-12)*60+b-12*b);
            else
                t[i].dis=abs(a*60+b-12*b);
            if(t[i].dis>360)
                t[i].dis=720-t[i].dis;
        }
        sort(t,t+5,cmp);
        cout<<t[2].s<<endl;
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值