HDOJ1171 Big Event in HDU 多重背包

题目链接 http://acm.hdu.edu.cn/showproblem.php?pid=1171

Problem Description

Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).

 

 

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.

 

 

Output

For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.

 

 

Sample Input

 

2 10 1 20 1 3 10 1 20 2 30 1 -1

 

 

Sample Output

 

20 10 40 40

 题目大意: 有n种物品,每种物品有一定数量和价值,要把这些物品分给A和B,要求A和B得到的物品总价值尽可能相等或接近,且A的价值不少于B,要求输出A和B得到的价值。

题解:先计算出物品的总价值V,则A得到的价值至少是V/2,B得到的价值最多为V/2。相当于在这些物品中挑选物品给B,总价值不得超过V/2,同时价值要尽可能大,这是比较典型的多重背包问题。

 

#include <cstdio>
#include <algorithm>
#include <cstring>
#define MAXN 55
using namespace std;
int value[MAXN], number[MAXN];					// 物品的价值和数量
int total;				// 背包总重量 
int dp[250005];			// dp数组 

int main(){
	int n;
	int temp;			// 临时保存总价值 
	while(scanf("%d",&n) != EOF) {
		if(n < 0)
			break;
		// 初始化 
		memset(dp,0,sizeof(dp));
		total = 0;
		for(int i = 1;i <= n;i++) {		
			scanf("%d%d",&value[i],&number[i]);
			total += number[i] * value[i];
		}
		temp = total;
		total /= 2;
		for(int i = 1;i <= n;i++)
			for(int j = 1;j <= number[i];j++)
				for(int k = total;k >= value[i];k--) {
					dp[k] = max(dp[k],dp[k-value[i]] + value[i]);
				}
		
		printf("%d %d\n",temp-dp[total],dp[total]);
		
	}

	return 0;
}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值