A - Division

A - Division

Write a program that finds and displays all pairs of 5-digit numbers that between them use the digits 0 through 9 once each, such that the first number divided by the second is equal to an integer N, where 2 ≤ N ≤ 79. That is, abcde fghij = N where each letter represents a different digit. The first digit of one of the numerals is allowed to be zero. Input Each line of the input file consists of a valid integer N. An input of zero is to terminate the program. Output Your program have to display ALL qualifying pairs of numerals, sorted by increasing numerator (and, of course, denominator). Your output should be in the following general form: xxxxx / xxxxx = N xxxxx / xxxxx = N . .
In case there are no pairs of numerals satisfying the condition, you must write ‘There are no solutions for N.’. Separate the output for two different values of N by a blank line.

Sample Input

61
62
0

Sample Output

There are no solutions for 61.
79546 / 01283 = 62
94736 / 01528 = 62
#include <iostream>
#include <cstdio>

using namespace std;

int main()
{
    int N, a, b, c, d, e, f, g, h, i, j, x, y;
    int t = 0, r = 0;
    while(scanf("%d", &N) && N !=0)
    {
        if(r >= 1)
        printf("\n");
        for(f = 0; f < 5; f++)
        for(g = 0; g < 10; g++)
        {
            if (g == f) continue;
            for(h = 0; h < 10; h++)
            {

                if(h == f || h == g) continue;
                for(i = 0; i < 10; i++)
                {
                    if(i == f || i == g || i == h) continue;
                    for(j = 0; j < 10; j++)
                    {
                        if(j == f || j == g || j == h || j == i) continue;
        {
            x =10000*f + 1000*g + 100*h + 10*i + j;
            y = N * x;
            e = y % 10; y = y / 10;
            d = y % 10; y = y / 10;
            c = y % 10; y = y / 10;
            b = y % 10; y = y / 10;
            a = y % 10; y = y / 10;
            if(y <= 0)
            {
                if(a != b && a != c && a != d && a != e && a != f && a != g && a != h && a != i && a != j &&
                   b != c && b != d && b != e && b != f && b != g && b != h && b != i && b != j &&
                   c != d && c != e && c != f && c != g && c != h && c != i && c != j &&
                   d != e && d != f && d != g && d != h && d != i && d != j &&
                   e != f && e != g && e != h && e != i && e != j &&
                   f != g && f != h && f != i && f != j &&
                   g != h && g != i && g != j &&
                   h != i && h != j &&
                   i != j
                   )
                    {
                        printf("%d%d%d%d%d / %d%d%d%d%d = %d\n", a, b, c, d, e, f, g, h, i, j ,N);
                        t++;
                    }
            }
         }
                    }
                }
            }
         }
         if(t == 0) printf("There are no solutions for %d.\n", N);
         t = 0;
         r++;
    }
    return 0;
}
   空行的问题  第一次输入最前面没有空行,只有在后续的输入中才有空行的输出
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值