问题描述
树是一种同学们都不陌生的数据结构,他有可能是一棵空树或是一些满足要求的节点链接而成的有向边的集合。
一棵树只有一个根节点,根节点没有指向他的边。
除了根节点的每一个节点都只有一条边指向它。
出现环的图都不是树,例如,下图中只有前两个图是一棵树,而第三个图不是。
在本题中,你将对一些节点连接而成的有向边的集合进行判定判定每组的输人数据构成的图是否是一棵树,
输入
每输人对都为0的数时,表示.组数据输人完毕 每条边由一对正整数表示,第一个数为有向边的起始边,第二个数为有向边的终止点,对负数的输人就表示输人的结束.
输出
中每组测试数据输出行判定结果, 若输人的图为树,则输出“"Case is a tee.",否则输出”“Case is not a tree ”“其中k表示每组数据的编号(编号从1开始)
样例输入
6 8 5 3 5 2 6 4 5 6 0 0
8 1 7 3 6 2 8 9 7 5 7 4 7 8 7 6 0 0
3 8 6 8 6 4
5 3 5 6 5 2 0 0
-1 -1
样例输出
Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
#define max 9999
int f[max];
int flag[max];
int init()
{
for(int i=0;i<=max;i++)
{
f[i]=i;
}
}
int find(int x)
{
if(x==f[x])
{
return x;
}
else
{
return find(f[x]);
}
}
int hebing(int x,int y)
{
int xx=find(x);
int yy=find(y);
if(yy!=y)//如果y连接到x上,要保证y的根节点是它自己。
{
return 1;
}
if(xx==yy)//如果他两个有同一个根节点,就不再合并 。
{
return 1;
}
else
{
f[yy]=xx;
}
return 0;
}
int main()
{
int n,m;
int maxx=0;
int t=0;
int cut=1;
int key=0;
init();
memset(flag,0,sizeof(0));
while(1)
{
cin>>n>>m;
if(n<=-1&&m<=-1)
{
break;
}
if(n>maxx)
{
maxx=n;
}
if(m>maxx)
{
maxx=m;
}
flag[n]=1;
flag[m]=1;
//cout<<key<<"==="<<endl;
if(n==0&&m==0)
{
for(int i=1;i<=maxx;i++)
{
if(flag[i]==1&&f[i]==i)
{
t++;
}
if(t>=2)
{
break;
}
}
//cout<<t<<endl;
if(t>=2||key>0)
{
cout<<"Case "<<cut++<<" "<<"is not a tree"<<endl;
}
else
{
cout<<"Case "<<cut++<<" "<<"is a tree"<<endl;
}
maxx=0;t=0;key=0;
init();
memset(flag,0,sizeof(flag));
continue;
}
key+=hebing(n,m);//这一行要放在最后,因为当n和m为0 0的时候,应该先执行 71行,如果将
//98行放在71行前的话,会先执行这一行,这样的话,0 0会算入到key的值里面
}
return 0;
}