Is It A Tree?

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 

There is exactly one node, called the root, to which no directed edges point. 
Every node except the root has exactly one edge pointing to it. 
There is a unique sequence of directed edges from the root to each node. 
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not. 


In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

题意:给出几组测试数据(以-1 -1结束),每组测试数据有几组数a,b(以0 0结束)表示从a,b相连,问能否构成·一个树,构成树的条件为   1.只有一个节点,称为根节点,没有定向边指向它    2.除了根节点外,每个节点都有一条指向它的边    3.从根到每个节点有一个独特的有向边序列。

注意:当树是空的时候也是满足条件的一种情况。

思路:这个题读过题后明白可以用并查集做,对于第一个条件 意思就是 只能有一个祖先,对应第三个条件,它的意思就是从一个点到另一个点只能有一条唯一路径,在实现的时候对输入的a,b,在a,b祖先不同时进行一个合并,使他们有相同祖先,然后接着输入,在每一次输入之后都要进行一个if (getf(a)==getf(b))的判断,如果相等说明之前从a到b已经有一条路径了,这个已经是第二条了,所以不能满足条件,在满足第三个条件的情况下最后判断一下有多少个祖先,如果多与一个不满足条件。代码如下:

#include<stdio.h>
#include<string.h>
int f[100005],book[100005],a[100005],b[100005],m,flag,k;
int getf(int v)
{
    if(f[v]==v)
        return v;
    else
    {
        f[v]=getf(f[v]);
        return f[v];
    }
}
void merge(int u,int v)
{
    int t1,t2;
    t1=getf(u);
    t2=getf(v);
    if(t1!=t2)
        f[t2]=t1;
}
int main()
{
    int i,x,y,l,p=1;
    while(~scanf("%d %d",&a[0],&b[0])&&(a[0]!=-1||b[0]!=-1))
    {
        if(a[0]==0&&b[0]==0)
        {
             printf("Case %d is a tree.\n",p++);
        continue;
        }
        memset(book,0,sizeof(book));
        for(i=1; i<=100005; i++)
            f[i]=i;
        l=1;
        m=1;
        flag=1;
        k=0;
        while(1)
        {
            scanf("%d %d",&x,&y);
            if(x==0&&y==0)
                break;
            else
            {
                m++;
                a[l]=x;
                b[l]=y;
                l++;
            }
        }
        for(i=0; i<l; i++)
        {
            if(book[a[i]]==0)
            {
                k++;
                book[a[i]]=1;
            }
            if(book[b[i]]==0)
            {
                book[b[i]]=1;
                k++;
            }
        }
        for(i=0; i<l; i++)
        {
            if(getf(a[i])==getf(b[i]))
            {
                flag=0;
                break;
            }
            else
                merge(a[i],b[i]);
        }
        if(flag==1)
        {
            int sum=0;
            for(i=1; i<=100005; i++)
            {
                if(book[i]==1)
                {
                    if(f[i]==i)
                        sum++;
                }
            }
        if(sum>1)
            flag=0;
        }
        if(flag==0)
        printf("Case %d is not a tree.\n",p++);
        else
            printf("Case %d is a tree.\n",p++);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值