hdoj 2023 杨辉三角

/*
杨辉三角
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 35210    Accepted Submission(s): 14697




Problem Description
还记得中学时候学过的杨辉三角吗?具体的定义这里不再描述,你可以参考以下的图形:
1
1 1
1 2 1
1 3 3 1
1 4 6 4 1
1 5 10 10 5 1


 


Input
输入数据包含多个测试实例,每个测试实例的输入只包含一个正整数n(1<=n<=30),表示将要输出的杨辉三角的层数。
 


Output
对应于每一个输入,请输出相应层数的杨辉三角,每一层的整数之间用一个空格隔开,每一个杨辉三角后面加一个空行。
 


Sample Input
2 3
 


Sample Output
1
1 1


1
1 1
1 2 1
 


*/
#include<stdio.h>
int main()
{
   int n;
   while(scanf("%d",&n)!=EOF)
   {
      int i,j,k,l;
      if(n==2)
      {
         printf("1\n1 1\n\n");        
      }
      else
      {
      int ch[32][32];
       for(i=0;i<n;i++)
       {
          ch[0][0]=1;
          ch[1][0]=1;
          for(j=1;j<n;j++)
          {
             ch[i][0]=1;
             ch[i][j]=ch[i-1][j-1]+ch[i-1][j];
             if(i==j)
             ch[i][j]=1;                
          }                
       } 
       for(k=0;k<n;k++)
       {
          for(l=0;l<n;l++)
          {
            printf("%d",ch[k][l]);
            if(l<k)
            printf(" ");
             if(l>=k)
             break;
          } 
            printf("\n");               
       } 
       printf("\n");                        
      }    
  }
   return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值