数据结构实验之链表五:单链表的拆分

Time Limit: 1000MS Memory limit: 65536K

题目描述

输入N个整数顺序建立一个单链表,将该单链表拆分成两个子链表,第一个子链表存放了所有的偶数,第二个子链表存放了所有的奇数。两个子链表中数据的相对次序与原链表一致。

输入

第一行输入整数N;;
第二行依次输入N个整数。

输出

第一行分别输出偶数链表与奇数链表的元素个数;
第二行依次输出偶数子链表的所有数据;
第三行依次输出奇数子链表的所有数据。

示例输入

10

1 3 22 8 15 999 9 44 6 1001

示例输出

4 6

22 8 44 6

1 3 15 999 9 1001

提示

不得使用数组!

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
struct node{
	int data;
	struct node *next;
}*head1,*head2;
int n=0,m=0;
struct node *creat(int n)
{
	int i;
	struct node *head,*tail,*p;
	head=(struct node *)malloc(sizeof(struct node));
	head->next=NULL;
	tail=head;
	for(i=0;i<n;i++){
		p=(struct node *)malloc(sizeof(struct node));
		scanf("%d",&p->data);
		p->next=NULL;
		tail->next=p;
		tail=p;
	}
	return head;
} 
void part(struct node *head)
{
	struct node *p1,*p2;
	head1=(struct node *)malloc(sizeof(struct node));
	head1->next=NULL;
	p1=head1;
	head2=(struct node *)malloc(sizeof(struct node));
	head2->next=NULL;
	p2=head2;
	while(head){
		if(head->data%2==0){
			p1->next=head;
			head=head->next;
			p1=p1->next;
			p1->next=NULL;
			n++;
		}
		else{
			p2->next=head;
			head=head->next;
			p2=p2->next;
			p2->next=NULL;
			m++;
		}
	}
}
int main()
{
	int N;
	struct node *head;
	scanf("%d",&N);
	head=creat(N);
	head=head->next;
	part(head);
	printf("%d %d\n",n,m);
	head1=head1->next;
	while(head1->next!=NULL){
		printf("%d ",head1->data);
		head1=head1->next;
	}
	printf("%d\n",head1->data);
	head2=head2->next;
	while(head2->next!=NULL){
		printf("%d ",head2->data);
		head2=head2->next;
	}
	printf("%d\n",head2->data);
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值