POJ - 2299 Ultra-QuickSort —— 逆序对

Ultra-QuickSort
Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 65956 Accepted: 24670

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0
题意:给定一个长度为n的序列,问逆序对是多少

思路:逆序对=对每个位置(i - 1~i中小于等于num[i]的数的个数)求和

用树状数组记录每个位置前小于等于的个数

注意 数特别大但规模很小,需离散化

最后要用ll储存结果

#include <iostream>
#include <cstdio>
#include <cmath>
#include <vector>
#include <stack>
#include <cstring>
#include <queue>
#include <algorithm>
#define ll long long
#define max_ 500100
#define inf 0x3f3f3f3f
#define mod 1000000007
using namespace std;
struct node
{
	int w;
	int pos;
	int id;
}num[max_];
int n;
int c[max_];
bool cmp1(const node &a,const node &b)
{
	return a.w<b.w;
}
bool cmp2(const node &a,const node &b)
{
	return a.id<b.id;
}
void add(int x)
{
	while(x<=n)
	{
		c[x]++;
		x+=x&-x;
	}
}
int getsum(int x)
{
	int sum=0;
	while(x>0)
	{
		sum+=c[x];
		x-=x&-x;
	}
	return sum;
}
int main(int argc, char const *argv[]) {
	while(scanf("%d",&n)!=EOF,n)
	{
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&num[i].w);
			num[i].id=i;
		}
		sort(num+1,num+1+n,cmp1);
		for(int i=1;i<=n;i++)
		num[i].pos=i;
		sort(num+1,num+1+n,cmp2);
		memset(c,0,sizeof(c));
		ll ans=0;
		for(int i=1;i<=n;i++)
		{
			add(num[i].pos);
			ans+=i-getsum(num[i].pos);
		}
		printf("%lld\n",ans );
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值