Uva 562— Dividing coins

It's commonly known that the Dutch have invented copper-wire. Two Dutch men were fighting over a nickel, which was made of copper. They were both so eager to get it and the fighting was so fierce, they stretched the coin to great length and thus created copper-wire.


Not commonly known is that the fighting started, after the two Dutch tried to divide a bag with coins between the two of them. The contents of the bag appeared not to be equally divisible. The Dutch of the past couldn't stand the fact that a division should favour one of them and they always wanted a fair share to the very last cent. Nowadays fighting over a single cent will not be seen anymore, but being capable of making an equal division as fair as possible is something that will remain important forever...


That's what this whole problem is about. Not everyone is capable of seeing instantly what's the most fair division of a bag of coins between two persons. Your help is asked to solve this problem.


Given a bag with a maximum of 100 coins, determine the most fair division between two persons. This means that the difference between the amount each person obtains should be minimised. The value of a coin varies from 1 cent to 500 cents. It's not allowed to split a single coin.

Input 

A line with the number of problems  n , followed by  n  times:
  • a line with a non negative integer m ($m \le 100$) indicating the number of coins in the bag
  • a line with m numbers separated by one space, each number indicates the value of a coin.

Output 

The output consists of  n  lines. Each line contains the minimal positive difference between the amount the two persons obtain when they divide the coins from the corresponding bag.

Sample Input 

2
3
2 3 5
4
1 2 4 6

Sample Output 

0
1
题意:将给出的硬币分成两份 使得两份的差距最小
分析:将总量的一半作为背包的容量,dp之后 求出最优值(一部分),即与sum/2最接近的值,总量减去这个数(这部分)便是剩下的价值(剩下的一部分)此时两部分的差就是结果。
法一:
代码:
#include<stdio.h>
#include<iostream>
#include<math.h>
#include<string.h>
#include<algorithm>
using namespace std;
int dp[30000];
int main()
{
    int t,m,coin[110];
    scanf("%d",&t);
    while(t--)
    {
        int sum=0;
        scanf("%d",&m);
        for(int i=1;i<=m;i++)
        {scanf("%d",&coin[i]);
            sum+=coin[i];
        }
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=m;i++)
            for(int j=sum/2;j>=coin[i];j--)
                dp[j]=max(dp[j],dp[j-coin[i]]+coin[i]);
        cout<<fabs(sum-dp[sum/2]-dp[sum/2])<<endl;
    }
    return 0;
}
法二:蒙大神指教,得另一解法。枚举所有可能出现的硬币组成的钱数,再从平均值开始判断,是否该钱数能被已有硬币组合成,找到第一个能组合的 ,剩下的便是另一部分的,两部分想减 便是差距
代码如下:
#include<cstdio>
#include<cstring>
#define MAXN 105
int c[MAXN];
bool dp[MAXN * 500];
int main()
{
    int t;
    scanf( "%d", &t);
    while( t--)
    {
        int m, C = 0;
        scanf( "%d", &m);
        memset( dp, false, sizeof (dp));
        for( int i = 0; i < m; i ++)
        {
            scanf( "%d", &c[i]);
            C += c[i];
        }
        dp[0] = true;//初始化,价值为零也是正确的分发
        for( int i = 0; i < m; i ++)
            for( int j = C; j >= c[i]; j --)
                if( dp[j - c[i]])
                    dp[j] = true;
        
        int div;
        for( int i = C / 2; i >= 0; i --)
            if( dp[i]) 
            {
                div = i;
                break;
            }
        int ans = C - 2 * div;
        printf( "%d\n", ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值