HDU Bone Collector

Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave … 
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ? 

 

Input

The first line contain a integer T , the number of cases. 
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output

One integer per line representing the maximum of the total value (this number will be less than 2  31).
 

Sample Input

       
       
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output

       
       
14
 
dp:一维数组:
#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<string.h>
using namespace std;
int dp[1100],a[1000],b[1000];
int main()
{
    int n,v,t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&v);
        for(int i=0; i<n; i++)
            scanf("%d",&a[i]);
        for(int i=0;i<n;i++)
            scanf("%d",&b[i]);
        memset(dp,0,sizeof(dp));
        for(int i=0; i<n; i++)
        {
            for(int j=v;j>=b[i];j--)
            {
                if(dp[j]<dp[j-b[i]]+a[i])//dp之后均更新成最优值,上次更新时某个剩余空间(〉=b[i])的价值+a[i]的价值,可能比上次dp[j]的值大。
                    dp[j]=dp[j-b[i]]+a[i];
            }
        }
        cout<<dp[v]<<endl;
    }
    return 0;
}


二维数组:
     
     
#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
int max(int a,int b)
{
    return a>b?a:b;
}
int t,cost[1100],value[1100],dp[1100][1100];
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        int n,v;
        scanf("%d%d",&n,&v);
        for(int i=1;i<=n;i++)
            scanf("%d",&value[i]);
        for(int i=1;i<=n;i++)
            scanf("%d",&cost[i]);
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
        {
            for(int j=0;j<=v;j++)
            {
                if(j>=cost[i])
                    dp[i][j]=max(dp[i-1][j],dp[i-1][j-cost[i]]+value[i]);
                else
                    dp[i][j]=dp[i-1][j];
            }
        }
        cout<<dp[n][v]<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值