Poj 1742—Coins 多重背包

Description

People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch. 
You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins. 

Input

The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8
4
题意:有n种面值的硬币,每种面值硬币有确定的数量,判断 给出的硬币能组合出多少种钱数,最大值不超过m;
分析:多重背包,模版稍作改动:
代码如下:
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
int w[10],n[10],f[200000],V;
int dp[110000];
struct node{
int v;
int n;
}a[110000];
void ZeroOnePack(int cost,int weight)//01背包
{
    int v;
    for(v=V; v>=cost; v--)
        if(f[v]<f[v-cost]+weight)
            f[v]=f[v-cost]+weight;
}
void CompletePack(int cost,int weight)//完全背包
{
    int v;
    for(v=cost; v<=V; v++)
        if(f[v]<f[v-cost]+weight)
            f[v]=f[v-cost]+weight;
}
void MultiplePack(int cost,int weight,int amount)//多重背包
{
    int k;
    if (cost*amount>=V)
    {
        CompletePack(cost,weight);
        return;
    }
    k=1;
    while(k<amount)
    {
        ZeroOnePack(k*cost,k*weight);
        amount=amount-k;
        k=k*2;
    }
    ZeroOnePack(amount*cost,amount*weight);
}
int main()
{
    int i,j,t=1,sum,m,b[110000];
    while(cin>>m>>V)
    {
        if(m==0&&V==0)
            break;
        for(i=0; i<m; i++)
            scanf("%d",&a[i].v);
        for(i=0; i<m; i++)
            scanf("%d",&a[i].n);
        memset(f,0,sizeof(f));memset(b,0,sizeof(b));
        for(i=0; i<m; i++)
            MultiplePack(a[i].v,a[i].v,a[i].n);
        int ans=0;
        for(i=1;i<=V;i++)
             b[f[i]]++;
        for(i=1;i<=f[V];i++)
            if(b[i])
                ans++;
                printf("%d\n",ans);
    }
    return 0;
}

只能通过完全背包求解,也有另一种思路,通过dp 将所有可能出现的钱数组合,找出,一次for循环遍历,计算出有多少种,但要注意背包容量最大值,他是m和总价值中德最小值;
<span style="font-size: 14px;">代码如下,但是会</span><span style="font-size:32px;">超时</span><span style="font-size: 14px;">:</span>
<pre name="code" class="cpp">#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;
int dp[110000];
struct node
{
    int v,n;
} a[110];

bool cmp(node a,node b)
{
    return a.v<b.v;
}
int main()
{
    int n,m,i,j,sum;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(n==0&&m==0)
            break;
        sum=0;
        for(i=0; i<n; i++)
            scanf("%d",&a[i].v);
        for(i=0; i<n; i++)
        {
            scanf("%d",&a[i].n);
            sum+=a[i].n*a[i].v;
        }
        if(m>sum)
          m=sum;//key;
        sort(a,a+n,cmp);
        memset(dp,0,sizeof(dp));
        dp[a[0].v]=1;
        for(i=0; i<n; i++)
            for(j=1; j<=a[i].n; j++)
                for(int k=m; k>=a[i].v; k--)
                        if(dp[k-a[i].v])
                            dp[k]=1;
        int ans=0;
        for(i=a[0].v; i<=m; i++)
        {
            if(dp[i]!=0)
                ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}




                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值