I Hate It(树状数组,线段树)

Problem Description
很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。
这让很多学生很反感。

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。
 

Input
本题目包含多组测试,请处理到文件结束。
在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。
学生ID编号分别从1编到N。
第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。
接下来有M行。每一行有一个字符 C (只取'Q'或'U') ,和两个正整数A,B。
当C为'Q'的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。
当C为'U'的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。
 

Output
对于每一次询问操作,在一行里面输出最高成绩。
 

Sample Input
  
  
5 6 1 2 3 4 5 Q 1 5 U 3 6 Q 3 4 Q 4 5 U 2 9 Q 1 5
 

Sample Output
  
  
5 6 5 9
树状数组:

#include <iostream>
#include<stdio.h>
#include<math.h>
#include<string.h>
using namespace std;

#define maxx 200005
#define max(a,b) ((a)>(b)?(a):(b))
int a[maxx],c[maxx],n,m;
int lowbit(int x)
{
    return x&(-x);
}

int querry(int a1,int b)
{
    int asas=a[b];
    while(a1!=b)//保证 能查询到符合的值,与士兵杀敌的sun函数有一点点相似
    {
        for(b=b-1; b-lowbit(b)>=a1; b-=lowbit(b))
        {
            asas=max(asas,c[b]);
        }
        asas=max(asas,a[b]);
    }
    return asas;
}
void add(int x,int d)
{
    a[x]=d;
    while(x<=n)
    {
        c[x]=max(c[x],d);//c数组保存的是最大的值,与士兵杀敌的add函数类似
        x+=lowbit(x);
    }
}
int main()
{
    int i,aa,bb;
    char cc;
    while(~scanf("%d%d",&n,&m))
    {
        memset(c, 0, sizeof(c));
        for(i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            add(i,a[i]);
        }
        for(i=0; i<m; i++)
        {
            getchar();//注意getchar();
            scanf("%c%d%d",&cc,&aa,&bb);
           // printf("***%c%d%d\n",cc,aa,bb);
            if(cc=='Q')
            {
                printf("%d\n",querry(aa,bb));
            }
            else
            {
                add(aa,bb);
            }
        }
    }
    return 0;
}
线段树:

#include <stdio.h>
#include <conio.h>
#include <string.h>

#define max(x1, y1) ((x1) > (y1) ? (x1) : (y1))
#define min(x1, y1) ((x1) < (y1) ? (x1) : (y1))

#define MAXSIZE 200005

typedef struct {
	int max ;
	int left, right ;
} NODE ;

int		n, m ;
int		a[MAXSIZE] ;
NODE	tree[MAXSIZE * 20] ;

// 构建线段树
int build (int root, int left, int right)
{
	int mid ;

	// 当前节点所表示的区间
	tree[root].left		= left ;
	tree[root].right	= right ;

	// 左右区间相同,则此节点为叶子,max 应储存对应某个学生的值
	if (left == right)
	{
		return tree[root].max = a[left] ;
	}
	mid = (left + right) / 2 ;

	// 递归建立左右子树,并从子树中获得最大值
	int a, b ;
	a = build (2 * root, left, mid) ;
	b = build (2 * root + 1, mid + 1, right) ;

	return tree[root].max = max (a, b) ;
}

// 从节点 root 开始,查找 left 和 right 之间的最大值
int find (int root, int left, int right)
{
	int mid ;
	// 若此区间与 root 所管理的区间无交集
	if (tree[root].left > right || tree[root].right < left)
		return 0 ;
	// 若此区间包含 root 所管理的区间
	if (left <= tree[root].left && tree[root].right <= right)
		return tree[root].max ;

	// 若此区间与 root 所管理的区间部分相交

	int a, b ;	// 不能这样 max (find(...), find(...));
	a = find (2 * root, left, right) ;
	b = find (2 * root + 1, left, right) ;

	return max (a, b) ;
}

// 更新 pos 点的值
int update (int root, int pos, int val)//update 函数之所以要返回值 是因为在a数组更新后会 影响最大值
{
	// 若 pos 不存在于 root 所管理的区间内
	if (pos < tree[root].left || tree[root].right < pos)
		return tree[root].max ;

	// 若 root 正好是一个符合条件的叶子
	if (tree[root].left == pos && tree[root].right == pos)
		return tree[root].max = val ;

	// 否则。。。。

	int a, b ;	// 不能这样 max (find(...), find(...));
	a = update (2 * root, pos, val) ;
	b =	update (2 * root + 1, pos, val) ;

	tree[root].max = max (a, b) ;

	return tree[root].max ;
}

int main ()
{
	char c ;
	int i ;
	int x, y ;
	while (scanf ("%d%d", &n, &m) != EOF)
	{
		for (i = 1 ; i <= n ; ++i)
			scanf ("%d", &a[i]) ;
		build (1, 1, n) ;

		for (i = 1 ; i <= m ; ++i)
		{
			getchar () ;
			scanf ("%c%d%d", &c, &x, &y) ;
			if (c == 'Q')
			{
				printf ("%d\n", find (1, x, y)) ;
			}
			else
			{
				a[x] = y ;
				update (1, x, y) ;
			}
		}
	}
	return 0 ;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值