hdoj 1016 Prime Ring Problem

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 34004    Accepted Submission(s): 15056


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 
代码:
 
#include<stdio.h>
#include<stdlib.h>
#include<math.h>
int n;
int a[25];  //用来记录最后的数字序列; 
int use[25];    //用来标记数字是否用过; 
int prime(int x)
{
	for(int i=2;i<=sqrt(x);i++)
	{
		if(x%i==0)
		return 0;
	}
	return 1;
}
void dfs(int v)        //表示当前所找到的数的个数; 
{
	int i;
	if(v==n&&prime(a[n-1]+1))    //当满足搜索条件时,即已经找到最后一个数并且最后一个数与第一个数的和也是素数; 
	{
		for(i=0;i<n;i++)
		printf(i==n-1?"%d\n":"%d ",a[i]);
	}
	else
	{
		for(i=2;i<=n;i++)
		{
			if(!use[i]&&prime(i+a[v-1]))  //如果从前面2开始搜索到一个数并且这个数与前面一个数的和是素数,则继续下一位的搜索(枚举暴搜)。 
			{
				a[v]=i;
				use[i]=1;
				dfs(v+1);
				use[i]=0;        //如果递归回来了表示这个数没有用到,重新标记为可用的。 

			}
		}
	}
}
int init()
{
	int i;
	for(i=0;i<n;i++)
	use[i]=0;
    a[0]=1;
}
int main()
{
	int t=1;
	while(scanf("%d",&n)!=EOF)
	{
		init();
		printf("Case %d:\n",t++);
		if(n==1)
		printf("1\n");
		else
		dfs(1);
		printf("\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值