hdoj 1698 Just a Hook 【线段树区间修改】

Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 23946    Accepted Submission(s): 11981


Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 

Sample Input
  
  
1 10 2 1 5 2 5 9 3
 

Sample Output
  
  
Case 1: The total value of the hook is 24.

 

题意:有T组数据,每组数据有n个人,然后有q种情况,每种情况有三个整数:x,y,z,表示从x到y的值变为z,n个人的初始值都为1;


代码:


#include<stdio.h> 
#include<string.h> 
#include<algorithm>  
#define M 100100  
using namespace std;  
int sum[M*4];  
int change[M*4];  
void pushup(int o) //向上更新和 
{  
    sum[o]=sum[o<<1]+sum[o<<1|1];  
}  
void build(int left,int right,int node)  
{  
    sum[node]=1; //初始值为1 
    change[node]=0; //初始化为所有节点均未标记 
    if(left==right)  
    {  
        return ;  
    }  
    int mid=(left+right)/2;  
    build(left,mid,node*2);  
    build(mid+1,right,node*2+1);  
    pushup(node);  
}  
void pushdown(int m,int node) //m为区间长度 
//对某一个区间进行改变,如果被标记了,在查询的时候就得把改变传给子节点,因为查询的并不一定是当前区间 
{  
    if(change[node])  //已经标记过,该区间被改变过 
    {  
        change[node*2]=change[node*2+1]=change[node];  //标记子节点 
        sum[node*2]=change[node]*(m-(m/2));//更新左儿子的和 
        sum[node*2+1]=change[node]*(m/2);//更新右儿子的和  
        change[node]=0;  
    }  
}  
void update(int left,int right,int node,int L,int R,int ch)  
{  
    if(L<=left&&R>=right)  
    {  
        change[node]=ch;  
        sum[node]=ch*(right-left+1);//更新代表某个区间的节点和,该节点不一定是叶子节点  
        return ;  
    }  
    pushdown(right-left+1,node);//向下传递  
    int mid=(right+left)/2;  
    if(L<=mid)  
    {  
        update(left,mid,node*2,L,R,ch);//更新左儿子  
    }  
    if(R>mid)  
    {  
        update(mid+1,right,node*2+1,L,R,ch);//更新右儿子  
    }  
    pushup(node); //向上传递更新和 
}  
int main()  
{  
    int T;  
    int n,q,x,y,z;  
    int k=1;  
    scanf("%d",&T);  
    while(T--)  
    {  
        scanf("%d%d",&n,&q);  
        build(1,n,1);  
        while(q--)  
        {  
            scanf("%d%d%d",&x,&y,&z);  
            update(1,n,1,x,y,z);  
        } 
        printf("Case %d: The total value of the hook is %d.\n",k++,sum[1]);  
    }  
    return 0;  
}




 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值