HDU - 1698 D - Just a Hook (线段树区间更新)


In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length. 



Now Pudge wants to do some operations on the hook. 

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks. 
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows: 

For each cupreous stick, the value is 1. 
For each silver stick, the value is 2. 
For each golden stick, the value is 3. 

Pudge wants to know the total value of the hook after performing the operations. 
You may consider the original hook is made up of cupreous sticks. 
Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases. 
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations. 
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind. 
Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example. 
Sample Input
1
10
2
1 5 2
5 9 3
Sample Output
Case 1: The total value of the hook is 24.


题意:第一行输入几组数据 ,第二行输入一个数n,表示构建线段树的数组长度,初始数组里面都为1,下面一行为输入要更改区间的次数m,下面m行,每行 前两个数代表的数区间,第三个数是这个区间里的所有数变为这个数;

我下面有线段树写:

不懂线段树的点进去先看懂:线段树详解
代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define Max 100010

struct node
{
	int abadd;//延迟标记 
	int sum;
}stu[3*Max];

int a[Max];

int build(int root,int star,int end) //建线段树 
{
	stu[root].abadd = 0;     //延迟标记初始为0; 
	if(star==end)
	{
		stu[root].sum = 1;
		return stu[root].sum;
	}
	int mid = (star+end)/2;
	int t1 = build(2*root+1,star,mid);
	int t2 = build(2*root+2,mid+1,end);
	return stu[root].sum = t1+t2;
}

void down_updat(int root,int star,int end) //延迟标记传给左右子节点 
{
	if(stu[root].abadd !=0)			
	{
		int k=stu[root].abadd;
		int mid = (star+end)/2;
		stu[2*root+1].abadd  = k;
		stu[2*root+2].abadd = k;
		stu[2*root+1].sum = (mid-star+1)*k;
		stu[2*root+2].sum = (end-mid)*k;
		stu[root].abadd = 0;			//自己的延迟标记清0 
	}
}

int updat(int root,int star,int end,int s1,int e1,int add) //只更新找的区间结点值,再加上个延迟标记 
{
	if(s1>end||e1<star)
		return stu[root].sum;
	if(star>=s1&&end<=e1)
	{
		stu[root].abadd = add;
		stu[root].sum = (end-star+1)*add;
		return stu[root].sum;	
	}
	
	down_updat(root,star,end);
		
	int mid = (star+end)/2;
	int t1 = updat(2*root+1,star,mid,s1,e1,add);
	int t2 = updat(2*root+2,mid+1,end,s1,e1,add);
	return stu[root].sum = t1 + t2;	
}
int main()
{
	int i,j,t;
	scanf("%d",&t);
	for(j=1;j<=t;j++)
	{
		int n,m;
		scanf("%d",&n);
		build(0,0,n-1);
		scanf("%d",&m);
		int s1,e1,z;

		for(i=0;i<m;i++)
		{
			scanf("%d%d%d",&s1,&e1,&z);
			s1--;
			e1--;
			updat(0,0,n-1,s1,e1,z);
		}
		printf("Case %d: The total value of the hook is %d.\n",j,stu[0].sum);
	}
	return 0;
} 




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值