HDU - 6152——Friend-Graph

Friend-Graph

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1298    Accepted Submission(s): 667


Problem Description
It is well known that small groups are not conducive of the development of a team. Therefore, there shouldn’t be any small groups in a good team.
In a team with n members,if there are three or more members are not friends with each other or there are three or more members who are friends with each other. The team meeting the above conditions can be called a bad team.Otherwise,the team is a good team.
A company is going to make an assessment of each team in this company. We have known the team with n members and all the friend relationship among these n individuals. Please judge whether it is a good team.
 

Input
The first line of the input gives the number of test cases T; T test cases follow.(T<=15)
The first line od each case should contain one integers n, representing the number of people of the team.( n3000 )

Then there are n-1 rows. The  i th row should contain n-i numbers, in which number  aij  represents the relationship between member i and member j+i. 0 means these two individuals are not friends. 1 means these two individuals are friends.
 

Output
Please output ”Great Team!” if this team is a good team, otherwise please output “Bad Team!”.
 

Sample Input
  
  
1 4 1 1 0 0 0 1
 

Sample Output
  
  
Great Team!
 

Source

最多有两个人互相不认识,最多有两个人互相认识。符合上述情况为  Great Team! ,反之 Bad Team! 。
显然认识或者不认识,如果构成三角关系,则是 Bad Team! ,再利用 抽屉原理 优化。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int main()
{
    int N;
    cin>>N;
    while(N--)
    {
        int vju=0,n,in[7][7],com[7]= {};
        cin>>n;
        if(n<=5)
            vju=1;
        for(int i=1; i<n; i++)
            for(int j=i+1; j<=n; j++)
            {
                int t;
                scanf("%d",&t);
                if(vju)
                    in[j][i]=in[i][j]=t;
            }
        if(vju)
        {
            int vju1=0,vju2=0;
            for(int i=1; i<n; i++)
                for(int j=i+1; j<=n; j++)
                    for(int k=j+1; k<=n; k++)
                    {
                        if(in[i][j]&&in[j][k]&&in[k][i])
                            vju1=1;
                        if(!(in[i][j]||in[j][k]||in[k][i]))
                            vju2=1;
                    }
            if(vju1||vju2)
                vju=0;
        }
        if(vju)
            cout<<"Great Team!"<<endl;
        else
            cout<<"Bad Team!"<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值