hdu6152 Friend-Graph (2017 ccpc 网络赛 (暴力 + 一个神奇的定理)

Friend-Graph

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 995    Accepted Submission(s): 512


Problem Description
It is well known that small groups are not conducive of the development of a team. Therefore, there shouldn’t be any small groups in a good team.
In a team with n members,if there are three or more members are not friends with each other or there are three or more members who are friends with each other. The team meeting the above conditions can be called a bad team.Otherwise,the team is a good team.
A company is going to make an assessment of each team in this company. We have known the team with n members and all the friend relationship among these n individuals. Please judge whether it is a good team.
 

Input
The first line of the input gives the number of test cases T; T test cases follow.(T<=15)
The first line od each case should contain one integers n, representing the number of people of the team.( n3000 )

Then there are n-1 rows. The  i th row should contain n-i numbers, in which number  aij  represents the relationship between member i and member j+i. 0 means these two individuals are not friends. 1 means these two individuals are friends.
 

Output
Please output ”Great Team!” if this team is a good team, otherwise please output “Bad Team!”.
 

Sample Input
  
  
1 4 1 1 0 0 0 1
 

Sample Output
  
  
Great Team!
 

Source
 

Recommend
liuyiding
 
  思路:Ramsey theorem( 拉姆齐定理 ),  n 个人中必定有 k 个人相识或 k 个人互不相识 n = 6,k = 3;
#include <cstdio>
#include <cstring>
#define maxn 6  //只考虑 n= 3,4,5 的情况即可,暴力
using namespace std;

int a[maxn][maxn];  //邻接矩阵 存储无向图
int main()
{
    int T,n;
    scanf("%d",&T);
    while(T--)
    {
        int flag=0;
        scanf("%d",&n);
        if(n>=6)
            flag=1;
        if(n==1 || n==2)
            flag=2;

        memset(a,0,sizeof a);
        int value;
        for(int i=1;i<=n-1;i++) {
            for(int j=1;j<=n-i;j++)
            {
                scanf("%d",&value);
                a[i][i+j]=1;
                a[j+i][i]=1;
            }
        }
        if(flag == 2)
            printf("Great Team!\n");
        else if(flag == 1)
            printf("Bad Team!\n");
        else if(flag == 0){
            for(int i=1;i<=n;i++) {
               for(int j=1;j<=n;j++) {
                  for(int k=1;k<=n;k++)
                  {
                      if(i==k || i==j || j==k)
                        continue;
                      //下面是 符合题目中说的, Bad 的两种情况
                      if(a[i][j]==1&&a[i][k]==1&&a[j][k]==1)  {  flag=1; break;  }
                      if(a[i][j]==0&&a[i][k]==0&&a[j][k]==0)  {  flag=1; break;  }
                  }
                  if(flag) break;
                }
                if(flag) break;
            }
            if(flag == 1)  printf("Great Team!\n");
            else    printf("Bad Team!\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值