POJ - 1001 - Exponentiation

Exponentiation
Time Limit: 500MS Memory Limit: 10000K
Total Submissions: 171554 Accepted: 41539

Description

Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. 

This problem requires that you write a program to compute the exact value of R n where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

Input

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

Output

The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.

Sample Input

95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12

Sample Output

548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201

Hint

If you don't know how to determine wheather encounted the end of input: 
s is a string and  n is an integer 
C++

while(cin>>s>>n)

{

...

}

c

while(scanf("%s%d",s,&n)==2) //to  see if the scanf read in as many items as you want

/*while(scanf(%s%d",s,&n)!=EOF) //this also work    */

{

...

}

Source


输入n,m,输出n的m次幂。。

func1获取有效数字。(写的有点繁琐)
func2大数乘法。

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
using namespace std;
int func1(char *a)
{
    int point=0,vju1=0;
    for(int i=0; i<6; i++)
        if(a[i]=='.')
            vju1=1;
    if(vju1)
        for(int i=5; i>=0; i--)
            if(!vju1)
                if(a[i]=='.')
                    break;
                else
                    point++;
            else if(a[i]!=48)
            {
                vju1=0;
                if(a[i]!='.')
                    point++;
                else
                    break;
            }
            else
                a[i]=0;
    int n=strlen(a),vju2=0,flag=0;
    char b[187];
    for(int i=0; i<n; i++)
    {
        if((vju2&&a[i]!='.')||(!vju2&&a[i]!=48&&a[i]!='.'))
            b[flag++]=a[i];
        if(!vju2&&a[i]!=48)
            vju2=1;
    }
    b[flag]=0;
    strcpy(a,b);
    return point;
}
void func2(char *a,char *b)
{
    char s[187];
    int n=strlen(a),m=strlen(b),t[187]= {};
    reverse(a,a+n);
    reverse(b,b+m);
    for(int i=0; i<n; i++)
        for(int j=0; j<m; j++)
            t[i+j]+=(a[i]-48)*(b[j]-48);
    for(int i=0; i<=180; i++)
        t[i+1]+=t[i]/10,t[i]=t[i]%10;
    int flag=0,vju=0;
    for(int i=185; i>=0; i--)
        if(vju)
            s[flag++]=t[i]+48;
        else if(t[i]!=0)
            vju=1,s[flag++]=t[i]+48;
    s[flag]=0;
    strcpy(a,s);
    reverse(b,b+m);
}
int main()
{
    char a[187];
    int n;
    while(cin>>a>>n)
    {
        int point=func1(a),t=n-1;
        char b[187];
        strcpy(b,a);
        while(t--)
            func2(a,b);
        int m=strlen(a);
        if(m-point*n<0)
        {
            cout<<'.';
            int temp=point*n-m;
            while(temp--)
                printf("0");
        }
        for(int i=0; i<m; i++)
        {
            if(i==m-point*n)
                printf(".");
            printf("%c",a[i]);
        }
        cout<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值