计蒜客————Jumbled Compass

  •  65.23%
  •  1000ms
  •  65536K


Jonas is developing the JUxtaPhone and is tasked with animating the compass needle. The API is simple: the compass needle is currently in some direction (between and 359 degrees, with north being 0,east being 90), and is being animated by giving the degrees to spin it. If the needle is pointing north,and you give the compass an input of 90, it will spin clockwise (positive numbers mean clockwise direction) to stop at east, whereas an input of 45 would spin it counterclockwise to stop at north west.

image.png

The compass gives the current direction the phone is pointing and Jonas’ task is to animate the needle taking the shortest path from the current needle direction to the correct direction.Many ifs, moduli, and even an arctan later, he is still not convinced his minimumDistance function is correct; he calls you on the phone.

Input

The first line of input contains an integer n(≤ n≤ 359), the current direction of the needle.The second line of input contains an integer n(≤ n≤ 359), the correct direction of the needle.

Output

Output the change in direction that would make the needle spin the shortest distance from n1to n2. A positive change indicates spinning the needle clockwise, and a negative change indicates spinning the needle counter-clockwise. If the two input numbers are diametrically opposed, the needle should travel clockwise. I.e., in this case, output 180 rather than 180

样例输入1
315
45
样例输出1
90
样例输入2
180
270
样例输出2
90
样例输入3
45
270
样例输出3
-135
给你一个罗盘,给你现在指向的方向,一个正确方向,问如何挪动最少的角度,纠正罗盘.(罗盘指针 0~359,+值为顺时针,-值为逆时针.当+-180都可以时输出180).
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cmath>
using namespace std;
int main(){
    int n,m;
    while(cin>>n>>m){
        int t=m-n;
        if(t<0) t+=360;
        else t=t%360;
        if(t<=360-t) printf("%d\n",t);
        else printf("%d\n",t-360);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值