POJ3468A Simple Problem with Integers

A Simple Problem with Integers

Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 140730 Accepted: 43637
Case Time Limit: 2000MS

Description

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

区间修改,区间查询,注意范围long long 就行了

#include<iostream>
#include<cstdio>
#define N 4*100000+5
using namespace std;
typedef long long LL;
struct node{
    LL r,l;
    LL f;//懒惰标记
    LL w;
}tree[N];

LL ans;

void pushup(LL pos)
{
    tree[pos].w=tree[pos<<1].w+tree[pos<<1|1].w;
}

void pushdown(LL pos)
{
    tree[pos<<1].f+=tree[pos].f;
    tree[pos<<1|1].f+=tree[pos].f;
    tree[pos<<1].w+=tree[pos].f*(tree[pos<<1].r-tree[pos<<1].l+1);
    tree[pos<<1|1].w+=tree[pos].f*(tree[pos<<1|1].r-tree[pos<<1|1].l+1);
    tree[pos].f=0;
}

void build(LL pos,LL ll,LL rr)
{
    tree[pos].l=ll;
    tree[pos].r=rr;
    tree[pos].f=0;
    if(tree[pos].l==tree[pos].r)
    {
        scanf("%lld",&tree[pos].w);
        return ;
    }
    LL mid=(ll+rr)>>1;
    build(pos<<1,ll,mid);
    build(pos<<1|1,mid+1,rr);
    pushup(pos);
}

void update(LL pos,LL ll,LL rr,LL zz)//区间更新
{
    if(ll<=tree[pos].l&&tree[pos].r<=rr)
    {
        tree[pos].w+=(tree[pos].r-tree[pos].l+1)*zz;
        tree[pos].f+=zz;
        return;
    }
    if(tree[pos].f)
    pushdown(pos);
    LL mid=(tree[pos].l+tree[pos].r)>>1;
    if(ll<=mid)
    update(pos<<1,ll,rr,zz);
    if(rr>mid)
    update(pos<<1|1,ll,rr,zz);
    pushup(pos);
}

void query(LL pos,LL ll, LL rr)//区间查询
{
    if(ll<=tree[pos].l&&tree[pos].r<=rr)
    {
        ans+=tree[pos].w;
        return ;
    }
    if(tree[pos].f)
        pushdown(pos);
    LL mid=(tree[pos].l+tree[pos].r)>>1;
    if(ll<=mid)
    query(pos<<1,ll,rr);
    if(rr>mid)
    query(pos<<1|1,ll,rr);
    pushup(pos);
}

int main()
{
    LL n,m,x,y,z;
    char p;
    //freopen("in.txt","r",stdin);
    while(~scanf("%lld%lld",&n,&m))
    {
        build(1,1,n);
        for(int i=0;i<m;i++)
        {
            scanf("%*c%c%lld%lld",&p,&x,&y);
            if(p=='Q')
            {
                ans=0;
                query(1,x,y);
                printf("%lld\n",ans);
            }
            else
            {
                scanf("%lld",&z);
                update(1,x,y,z);
            }
        }
    }
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值