Hdu2054:A==B?大数高精度算法

27 篇文章 0 订阅
12 篇文章 0 订阅

Problem Description
Give you two numbers A and B, if A is equal to B, you should print “YES”, or print “NO”.

Input
each test case contains two numbers A and B.

Output
for each case, if A is equal to B, you should print “YES”, or print “NO”.

Sample Input
1 2
2 2
3 3
4 3

Sample Output
NO
YES
YES
NO

#include<stdio.h>
#include<stdlib.h>
#include<string.h>

void test(char a[],int end){      //去掉小数点后的0
    if(strstr(a,".")){            //判断数组带不带小数点
        while(a[end-1]=='0'){
            a[end-1]='\0';
            end--;
        }
        if(a[end-1]=='.'){
            a[end-1]='\0';
        }
    }
}

int main(){
    char a[100000],b[100000];    //把数组设的足够大
    while(~scanf("%s%s",a,b)){
        test(a,strlen(a));
        test(b,strlen(b));
        if(!strcmp(a,b))
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值