POJ1094 Sorting It All Out【拓扑排序】

Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three:

Sorted sequence determined after xxx relations: yyy...y.
Sorted sequence cannot be determined.
Inconsistency found after xxx relations.

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence.

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

解题思路

题目大意:用小于号"<"来定义两元素之间的关系,并于一个没有重复元素的有序上升序列 从小到大地排列这些元素。比如说,序列A,B,C,D意味着A<B;B<C;C<D。在这个问题里,我们会给你一组形如"A<B"的关系,询问你有序序列的合法性。其实就是给定一组字母的大小关系判断它们是否能组成唯一的拓扑序列。

思路:

  1. 先判断是否有环(一旦发现找不到入度为0的结点,立即return)
  2. 再判断是否严格有序(当每一步能且只能找到一个度为0的结点,则输出)
  3. 最后才能判断是否能得出结果(当发现无法确定时,并不能立即return,因为还需要判断是否有环)。
  4. 当发现多个结点的度为0时,则不是严格有序。当发现没有结点入度为0时,则必须遍历完整个图才能知道是否有环。
#include<iostream>
#include<queue>
#include<cstring>
using namespace std;

int n, m;
char s[10];
int indegree[30];
int map[30][30];
vector<int> ans;

int topologicalSort()
{
	int tmp[30];
	int flag = 1;
	ans.clear();
	for (int i = 1; i <= n; i++)
		tmp[i] = indegree[i];
	for (int i = 1; i <= n; i++)
	{
		int cnt, node;
 
		cnt = 0;
		for (int j = 1; j <= n; j++)
			if (tmp[j] == 0)
			{
				cnt++;
				node = j;
			}
		if (!cnt)
			return 0;
		if (cnt > 1) flag = -1;
		ans.push_back(node);
		tmp[node] = -1;
		for (int i = 1; i <= n; i++)
			if (map[node][i])
				tmp[i]--;
	}
	return flag;
}

int main()
{
	while (scanf("%d%d", &n, &m))
	{
		if (n == 0 && m == 0)
			break;
		memset(indegree, 0, sizeof(indegree));
		memset(map, 0, sizeof(map));
		int fin = 0;
		for (int i = 1; i <= m; i++) 
		{
			scanf("%s", s);
			if (fin)continue;
			int u = s[0] - 'A' + 1;
			int v = s[2] - 'A' + 1;
			map[u][v] = 1;
			indegree[v]++;
			int flag = topologicalSort();
			if (flag == 0)
			{
				printf("Inconsistency found after %d relations.\n",i);//注意标点符号
				fin = 1;
			}
			else if (flag == 1)
			{
				printf("Sorted sequence determined after %d relations: ",i);
				for(int j=0;j<ans.size();j++)
				{
					printf("%c", ans[j] + 'A' - 1);
				}
				printf(".\n");
				fin = 1;
			}
		}
		if(!fin)
			printf("Sorted sequence cannot be determined.\n");
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

胡小涛

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值