poj 2456 Aggressive cows (二分查找)



Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS:

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.

Huge input data,scanf is recommended.

题意:
有n个牛舍,每个牛舍有自己的位置xi(可以理解为坐标),把c头牛放在这n个牛舍里面,要求最近的两头牛之间的最大距离。
思路:

比如测试数据 5个牛舍 3头牛 牛舍坐标1 2 8 4 9

先按贪心,第一头牛肯定被放在第一个牛舍里,排序 1 2 4 8 9

第二头牛可以放在2,也可以放在4,假设第二头牛放在2 ,与第一头牛的距离为1 ,假设第三头放在9,与第二头的距离为7,那么,最近的两头牛之间的最大距离为1

最有解为 第一头牛放在1  第二头牛放在4 ,第三头牛放在9 ,那么 4-1=3  9-4=5 ,最近的两头牛之间的最大距离为3

也就是求相邻两头牛之间距离的最小值(取最大)。这个距离采用二分的形式进行判断。

#include<iostream>
#include<algorithm>
using namespace std;
int a[100005];
bool judge(int m,int C,int N){
    int b=0,gu;//b为当前牛舍的位置
    for(int i=1;i<C;i++){
        gu=b+1;
        while(gu<N&&a[gu+1]-a[b+1]<m)
            gu++;
        if(gu==N)
            return false;
        b=gu;//把第i头牛放进编号为gu的牛舍里
    }
    return true;
}
int main()
{
    int n,c;
    std::ios::sync_with_stdio(false);//c++流输入加速器
    while(cin>>n>>c){
        for(int i=1;i<=n;i++){
            cin>>a[i];
        }
        sort(a+1,a+n+1);
        int left=1,right=10e6+5,mid;
        for(int i=1;i<100;i++){
            mid=(left+right)/2;
            if(judge(mid,c,n))
                left=mid;
            else
                right=mid;
        }
        cout<<left<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值