HDU 3038 How Many Answers Are Wrong (带权并查集)

Problem Description

TT and FF are ... friends. Uh... very very good friends -________-b

FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored).


Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF's question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers.

Boring~~Boring~~a very very boring game!!! TT doesn't want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose.

The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence.

However, TT is a nice and lovely girl. She doesn't have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed.

What's more, if FF finds an answer to be wrong, he will ignore it when judging next answers.

But there will be so many questions that poor FF can't make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy)

 

Input

Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions. Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It's guaranteed that 0 < Ai <= Bi <= N. You can assume that any sum of subsequence is fit in 32-bit integer.

 

Output

A single line with a integer denotes how many answers are wrong.

 

Sample Input

10 5

1 10 100

7 10 28

1 3 32

4 6 41

6 6 1

 

Sample Output

1

 

题意:给N个数,M次询问,每次询问给a,b,s三个数,意思是从 a 到 b 这些数的和为 s,问有几个询问是错误的。

这道题就是带权并查集的应用,题目本身不是很难,刚开始也是一头雾水,后来同学给我讲了一下,忽然就明白了。

重点是这部分

int join(int a, int b, int s)
{
	int fa = find(a), fb = find(b);
	if (fa != fb)//如果不相等的话,就说明不能判断他是对还是错,就把它加到条件里
	{
		f[fb] = fa;
		v[fb] = v[a] + s - v[b];
	}
	else//如果相等的话就说明他们的差值可以算出来,此时就只需要判断集合差是否与给定值矛盾,矛盾就让错误答案+1
	{
		if (v[b] - v[a] != s)
			ans++;
	}
	return ans;
}

这段代码就是这道题的核心,fa和fb为a和b的祖先,如果fa=fb,就可以将v[fb]所表示的那一段算出来,公式就是v[fb] = v[a] + s - v[b],至于这个公式怎么来的,看下图:

v[r2] + v[b] = v[a] + s,所以v[fb] = v[a] + s - v[b]

还有就是怎样找祖先和更新权值

拿第一组数据来说

1 10 100         f[1-1]=f[0]=0       f [10]=10         f[f[10]]=f[10]= 0

7 10 28           f[7-1]=f[6]=6       f[10]=0            ``````f[f[10]]=f[0]=0

后面的跟上面一样,代码如下

int find(int x)
{
	if (x == f[x])
		return x;
	else
	{
		int t = find(f[x]);
		v[x] += v[f[x]];//根据父节点的权值更新自己的权值
		return f[x] = t;
	}
}
//特别注意,要先更新权值再赋值,否则就错了!!

其他的就不用说了,具体看代码

#include<iostream>
#include<iostream>
#include<string.h>
#include<stdio.h>
#include<algorithm>
using namespace std;
#define MAXN 200100
int f[MAXN], v[MAXN];
int a, b, s;
int n, m;
int ans;
int find(int x)
{
	if (x == f[x])
		return x;
	else
	{
		int t = find(f[x]);
		v[x] += v[f[x]];
		return f[x] = t;
	}
}
int join(int a, int b, int s)
{
	int fa = find(a), fb = find(b);
	if (fa != fb)
	{
		f[fb] = fa;
		v[fb] = v[a] + s - v[b];
	}
	else
	{
		if (v[b] - v[a] != s)
			ans++;
	}
	return ans;
}
int main()
{
	while (~scanf("%d%d", &n, &m))
	{
		ans = 0;
		for (int i = 0; i <= n; i++)
		{
			f[i] = i;
			v[i] = 0;
		}
		for (int i = 0; i < m; i++)
		{
			scanf("%d%d%d", &a, &b, &s);
			join(a - 1, b, s);
		}
		printf("%d\n", ans);
	}
}

并查集不懂的可以参考这篇博客:https://blog.csdn.net/loven0326/article/details/81502611

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值