华为OJ_1960_字符串分割

输入:  
连续输入字符串(输入2次,每个字符串长度小于100)
 
输出:  
输出到长度为8的新字符串数组
 
样例输入:
abc
123456789
                   
样例输出:
abc00000
12345678
90000000


#include <iostream>
#include <string>

using namespace std;

int main( void )
{
	int i = 2;
	string line;

	while( i-- ){
		getline( cin, line );
		int nLen = line.length();
		int nLenApp = nLen / 8 * 8 + 8;
		for( int j = 0; j < nLenApp; ++j ){
			if( j % 8 == 0 && j > 0 )
				cout << endl;
			if( j < nLen )
				cout << line[j];
			else
				cout << '0';
		}
		cout << endl;
	}

	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值