HOSTOJ 1032:寻找2的幂

Description

 
数学上把2的K次方叫2的K次幂,如4、8、32等。给定一个整数n,请输出距离它最近的那个2的幂是多少。如果有两个距离相同,输出那个小的。

Input

只有一个整数 n(10 <= n <= 2000000000)

Output

只有一个整数,表示距离 最近的那个2的幂。

Sample Input

17

Sample Output

16

 

<span style="font-family:Times New Roman;">#include<cstdio>
#include<cassert>

int main(){
	int num,temp=1,before,now;
	scanf("%d",&num);
	assert(num>=10 && num<=2000000000);

	while(temp<num){
		temp = temp << 1;
	}
	now =temp;
	before = temp >> 1;

	if((num-before)==(now-num)) ///重点两个相等时候的处理,取较小的那个
		printf("%d\n",before);
	else
	    printf("%d\n",(num-before)<(now-num) ? before : now);
	return 0;
}</span>


Important:if((num-before)==(now-num)) ///重点两个相等时候的处理,取较小的那个.

欢迎关注南阁公众号


南阁

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值