hdu 1394 最小逆序数 线段树单点增减,区间求和

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14883    Accepted Submission(s): 9085


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
  
  
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
  
  
16
 

题意:主要是利用线段树求逆序树,建的是一棵空树,然后每插入一个点之前,统计大于这个数的有多少个,直到所有的数都插入完成,就结果了逆序树的统计。

要得出答案主要是利用了一个结论,如果是0到n的排列,那么如果把第一个数放到最后,对于这个数列,逆序数是减少y[i],而增加n-1-y[i]的。(可以这样想,因为是第一个数,所有的数都在它后面,那么在当前位置pos比它大的数也在它后面,那么第一个数调到后面之后,在pos不成立的逆序数就成立了,所以多了n-y[i]-1,但是也少了在pos成立的逆序数,即y[i]个)

其中build 函数建树是不必要的,因为在update函数中相当于建树过程了

#include<cstdio>
#include<algorithm>
#include<iostream>
#include<string.h>
using namespace std;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
const int maxn=5005;
int sum[maxn<<2];
void PushUP(int rt)
{
    sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void build(int l,int r,int rt)
{
    sum[rt]=0;
    if(l==r)return;
    int m=(l+r)>>1;
    build(lson);
    build(rson);
}
void update(int p,int l,int r,int rt)
{
    if(l==r){
        sum[rt]++;
        return;
    }
    int m=(l+r)>>1;
    if(p<=m)update(p,lson);
    else update(p,rson);
    PushUP(rt);
}
void test(int n)
{
    for(int i=0;i<n*4;i++)
        cout<<sum[i]<<' ';
    cout<<endl;
}
int query(int L,int R,int l,int r,int rt)
{
    if(L<=l&&r<=R)return sum[rt];
    int m=(l+r)>>1;
    int ret=0;
    if(L<=m)ret+=query(L,R,lson);
    if(R>m)ret+=query(L,R,rson);
    return ret;
}
int x[maxn];
int main()
{
    int n;
    while(~scanf("%d",&n)){
        memset(sum,0,sizeof(sum));
       //build(0,n-1,1);
        int sum=0;
        for(int i=0;i<n;i++){
            scanf("%d",&x[i]);
            sum+=query(x[i],n-1,0,n-1,1);
           // test(n-1);
            update(x[i],0,n-1,1);
           // test(n-1);
           // cout<<sum<<' ';
        }
      //  cout<<endl;
        int ans=sum;
        for(int i=0;i<n;i++){
            sum+=n-x[i]-1-x[i];
            ans=min(ans,sum);
        }
        printf("%d\n",ans);
    }
    return 0;
}

#include <cstdio>
#include <algorithm>
#include<cstring>
using namespace std;
#define lson l , m , rt << 1
#define rson m + 1 , r , rt << 1 | 1
const int maxn = 5555;
int sum[maxn<<2];
void PushUP(int rt) {
    sum[rt] = sum[rt<<1] + sum[rt<<1|1];
}
void update(int p,int l,int r,int rt)
{
    if(l==r){
        sum[rt]=1;
        return;
    }
    int m=(l+r)>>1;
    if(p<=m)update(p,lson);
    else update(p,rson);
    PushUP(rt);
}
int query(int L,int R,int l,int r,int rt)
{
    if(L<=l&&r<=R){
        return sum[rt];
    }
    int m=(l+r)>>1;
    int ret=0;
    if(L<=m)ret+=query(L,R,lson);
    if(R>m)ret+=query(L,R,rson);
    return ret;
}
int x[maxn];
int main() {
    int n;
    while (~scanf("%d",&n)) {
      //  build(0 , n - 1 , 1);
      memset(sum,0,sizeof(sum));
        int sum = 0;
        for (int i = 0 ; i < n ; i ++) {
            scanf("%d",&x[i]);
            sum += query(x[i] , n - 1 , 0 , n - 1 , 1);
            update(x[i] , 0 , n - 1 , 1);
        }
        int ret = sum;

        for (int i = 0 ; i < n ; i ++) {
            sum += n - x[i] - x[i] - 1;
            ret = min(ret , sum);
        }
        printf("%d\n",ret);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值