例题 6-7 树的层次遍历 UVa 122 建树+宽度优先遍历

Background

Trees are fundamental in many branches of computer science. Current state-of-the art parallel computers such as Thinking Machines' CM-5 are based on fat trees. Quad- and octal-trees are fundamental to many algorithms in computer graphics.

This problem involves building and traversing binary trees.

The Problem

Given a sequence of binary trees, you are to write a program that prints a level-order traversal of each tree. In this problem each node of a binary tree contains a positive integer and all binary trees have have fewer than 256 nodes.

In a level-order traversal of a tree, the data in all nodes at a given level are printed in left-to-right order and all nodes at level k are printed before all nodes at level k+1.

For example, a level order traversal of the tree

picture28

is: 5, 4, 8, 11, 13, 4, 7, 2, 1.

In this problem a binary tree is specified by a sequence of pairs (n,s) where n is the value at the node whose path from the root is given by the string s. A path is given be a sequence of L's and R's where L indicates a left branch and R indicates a right branch. In the tree diagrammed above, the node containing 13 is specified by (13,RL), and the node containing 2 is specified by (2,LLR). The root node is specified by (5,) where the empty string indicates the path from the root to itself. A binary tree is considered to be completely specified if every node on all root-to-node paths in the tree is given a value exactly once.

The Input

The input is a sequence of binary trees specified as described above. Each tree in a sequence consists of several pairs (n,s) as described above separated by whitespace. The last entry in each tree is (). No whitespace appears between left and right parentheses.

All nodes contain a positive integer. Every tree in the input will consist of at least one node and no more than 256 nodes. Input is terminated by end-of-file.

The Output

For each completely specified binary tree in the input file, the level order traversal of that tree should be printed. If a tree is not completely specified, i.e., some node in the tree is NOT given a value or a node is given a value more than once, then the string ``not complete'' should be printed.

Sample Input

(11,LL) (7,LLL) (8,R)
(5,) (4,L) (13,RL) (2,LLR) (1,RRR) (4,RR) ()
(3,L) (4,R) ()

Sample Output

5 4 8 11 13 4 7 2 1
not complete

分析:根据给的节点建树,然后bfs遍历输出节点值,遍历可以用一个队列来完成,也可以用数组来模拟一下,直接输出

#include <algorithm>
#include <iostream>
#include <cstdlib>
#include <cstring>
#include <cstdio>
#include <cmath>
#include<list>
#include<deque>
#define LL long long
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
const int maxn=20;
struct tnode
{
    int V;
    tnode* L;
    tnode* R;
};
tnode node[300];
tnode* root;
int tree_size,complete;
int test(tnode *root)
{
    if(!root->V)return 0;
    int ans=0;
    if(!root->L||test(root->L))ans++;
    if(!root->R||test(root->R))ans++;
    return ans==2;
}
void buildtree(tnode *root,char* str,int v)
{
    if(*str=='R'){
        if(!root->R)
            root->R=&node[++tree_size];
        buildtree(root->R,str+1,v);
    }
    else if(*str=='L'){
        if(!root->L)
            root->L=&node[++tree_size];
        buildtree(root->L,str+1,v);
    }
    else{
        if(root->V)
            complete=0;
        root->V=v;
    }
}
tnode* Q[300];
void output(tnode* root)
{
    int move=0,save=0;
    Q[save++]=root;
    printf("%d",root->V);
    while(move<save){
        tnode* now=Q[move++];
        if(now->L){
            printf(" %d",now->L->V);
            Q[save++]=now->L;
        }
        if(now->R){
            printf(" %d",now->R->V);
            Q[save++]=now->R;
        }
    }
    printf("\n");
}
int main()
{
    char buf[256],leaf[256];
    int value;
    complete=1;
    root=&node[tree_size=0];
    while(scanf("%s",buf)!=EOF){
        if(!strcmp(buf,"()")){
            if(!complete||!test(root)){
                printf("not complete\n");
            }
            else output(root);
            memset(node,0,sizeof(node));
            root=&node[tree_size=0];
            complete=1;
        }
        else{
            sscanf(buf,"(%d,%s",&value,leaf);
            buildtree(root,leaf,value);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值