PAT 甲级 1030 Travel Plan(Dijkstra 以及 Dijkstra+DFS)

A traveler’s map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (≤500) is the number of cities (and hence the cities are numbered from 0 to N−1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:

City1 City2 Distance Cost

where the numbers are all integers no more than 500, and are separated by a space.

Output Specification:

For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.

Sample Input:

4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20

Sample Output:

0 2 3 3 40
解题思路:本题给出几个城市以及他们之间的高速公路,以及两个城市高速公路的距离与花费,当最短路径相同时取花费最少的那一条路径。最后要求输出最短路径,总距离以及花费。
  1. 通过Dijkstra直接处理,第一标度为距离,第二标度为花费,直接在求出最短路径时筛选最少花费。
#include<cstdio> 
#include<vector>
#include<algorithm>
using namespace std;
struct node {
	int n;
	int cost;
	int dis;
	node(int _n, int _cost, int _dis) {
		n = _n;
		cost = _cost;
		dis = _dis;
	}
	node() {}
};
const int INF = 1000000000;
const int MAXV = 1000;
int N, M, S, D;
int pre[MAXV];
int d[MAXV];
vector<node> Adj[MAXV];
int vis[MAXV] = { 0 };
int cost[MAXV];
void Dijkstra(int n) {
	for (int i = 0; i < N; i++)
		pre[i] = i;
	fill(d, d + MAXV, INF);
	fill(cost, cost + MAXV, INF);
	d[n] = 0;
	cost[n] = 0;
	for (int i = 0; i < N; i++) {
		int u = -1, MIN = INF;
		for (int j = 0; j < N; j++) {
			if (vis[j] == 0 && d[j] < MIN) {
				MIN = d[j];
				u = j;
			}
		}
		if (u == -1)	return;
		vis[u] = 1;
		for (int j = 0; j < Adj[u].size(); j++) {
			node next = Adj[u][j];
			if (vis[next.n] == 0) {
				if (d[u] + next.dis < d[next.n]) {
					d[next.n] = d[u] + next.dis;
					pre[next.n] = u;
					cost[next.n] = cost[u] + next.cost;
				}
				else if (d[u] + next.dis == d[next.n] && cost[u] + next.cost < cost[next.n]) {
					cost[next.n] = cost[u] + next.cost;
					pre[next.n] = u;
				}
			}
		}
	}
}
void DFS(int D)
{
	if (pre[D] == D) {
		printf("%d ", pre[D]);
		return;
	}
	DFS(pre[D]);
	printf("%d ", D);
}
int main(void) {
	scanf("%d %d %d %d", &N, &M, &S, &D);
	for (int i = 0; i < M; i++) {
		int a, b, length, cost;
		scanf("%d %d %d %d", &a, &b, &length, &cost);
		node Node(a, cost, length);
		Adj[b].push_back(Node);
		node Node1(b, cost, length);
		Adj[a].push_back(Node1);
	}
	Dijkstra(S);
	DFS(D);
	printf("%d %d", d[D], cost[D]);
	return 0;
}
  1. Dijkstra+DFS固定模板Dijkstra算法中求出所有的最短路径,在DFS中找出花费最少的路径并存储。
#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;
const int MAXV = 1000;
const int INF = 1000000000;
int N,M,S,D;
int Adj[MAXV][MAXV];
int vis[MAXV] = {0};
int Cost[MAXV][MAXV] = {0};
int d[MAXV];
vector<int> pre[MAXV];
void Dijkstra(int n){
	fill(d,d+MAXV,INF);
	d[n] = 0;
	for(int i = 0;i < N;i++){
		int u = -1,MIN = INF;
		for(int j = 0;j < N;j++){
			if(vis[j] == 0&&d[j]<MIN){
				MIN = d[j];
				u = j;
			}
		}
		if(u == -1)	return;
		vis[u] = 1;
		for(int j = 0;j < N;j++){
			if(vis[j] == 0&&Adj[u][j]!=INF){
				if(d[u]+Adj[u][j] < d[j]){
					d[j] = d[u] + Adj[u][j];
					pre[j].clear();
					pre[j].push_back(u);	
				}else if(d[u]+Adj[u][j] == d[j]){
					pre[j].push_back(u);
				}
			}
		}
	}
}
vector<int> temppath,path;
int minvalue = INF;
void DFS(int v){
	if(v == S){
		int value = 0;
		temppath.push_back(v);
		for(int i = temppath.size() - 1;i > 0;i--){
			int id = temppath[i],idnext =temppath[i - 1];
			value+=Cost[id][idnext];
		}
		if(value < minvalue){
			minvalue = value;
			path = temppath;
		}
		temppath.pop_back();
		return;
	}
	temppath.push_back(v);
	for(int i = 0;i < pre[v].size();i++){
		DFS(pre[v][i]);
	}
	temppath.pop_back();
}
int main(void){
	fill(Adj[0],Adj[0]+MAXV*MAXV,INF);
	scanf("%d %d %d %d",&N,&M,&S,&D);
	for(int i = 0;i < M;i++){
		int a,b,dis,cost;
		scanf("%d %d %d %d",&a,&b,&dis,&cost);
		Adj[a][b] = dis;
		Adj[b][a] = dis;
		Cost[a][b] = cost;
		Cost[b][a] = cost;
	}
	Dijkstra(S);
	DFS(D);
	for(int i = path.size()-1;i>=0;i--){
		printf("%d ",path[i]);
	}
	printf("%d %d",d[D],minvalue);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值