PAT 甲级 1075 PAT Judge(第5个测试点解决方法)

The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (≤10^4​​ ), the total number of users, K (≤5), the total number of problems, and M (≤10^5​​ ), the total number of submissions. It is then assumed that the user id’s…are 5-digit numbers from 00001 to N, and the problem id’s are from 1 to K. The next line contains K positive integers p[i] (i=1, …, K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either −1 if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] … s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then “-” must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id’s. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output:

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

解题思路:

  1. 输入的成绩为-1指未通过编译,根据题意所有题目都未通过编译或者都未提交的考生不输出,能够输出的考生若有题目成绩为 -1 则输出 0,有题目未提交输出’-’。所以将每个考生的所有题目初值设为-2,如果输入的题目成绩大于当前考生的成绩则更新考生成绩。若输入的成绩大于-1将flag置为1.表示当前考生能够输出。
  2. 输出顺序先比较排名,若排名相同比较得满分的题目数,若仍然相同按照考生ID升序输出。所以编写如下cmp函数。
bool cmp(struct submission a,struct submission b)
{
	if(a.total != b.total)
		return a.total > b.total;
	else if(a.perfect != b.perfect)
		return a.perfect > b.perfect;
	else 
		return a.ID < b.ID;
}

完整代码:

#include<cstdio>
#include<algorithm>
using namespace std;
struct submission
{
	int ID;
	int score[5];
	int total;
	int perfect;
	int rank;
	int flag;
}a[10000];
bool cmp(struct submission a,struct submission b)
{
	if(a.total != b.total)
		return a.total > b.total;
	else if(a.perfect != b.perfect)
		return a.perfect > b.perfect;
	else 
		return a.ID < b.ID;
}
int main(void)
{
	int N,K,M;
	scanf("%d %d %d",&N,&K,&M);
	int perfect_grade[K];
	for(int i = 0;i < K;i++)
	{
		scanf("%d",&perfect_grade[i]);
	}
	for(int i = 0;i < N;i++)
	{
		a[i].ID = i + 1;
		a[i].perfect = 0;
		a[i].flag = 0;
		for(int j = 0;j < K;j++)
		{
			a[i].score[j] = -2;
		}
	}
	int tempid,temppro,tempscore;
	for(int i = 0;i < M;i++)
	{
		scanf("%d %d %d",&tempid,&temppro,&tempscore);
		if(a[tempid - 1].score[temppro - 1] == perfect_grade[temppro - 1])
			continue;  											//重要否则第五个测试点通不过 
		else if(a[tempid - 1].score[temppro - 1] < tempscore)
		{
			a[tempid - 1].score[temppro - 1] = tempscore;
			if(	a[tempid - 1].score[temppro - 1] > -1)
				a[tempid - 1].flag = 1;
		}
		if(tempscore == perfect_grade[temppro - 1])
		{
			a[tempid - 1].perfect++;
		}
	}
	for(int i = 0;i < N;i++)
	{
		int temptotal = 0;
		for(int j = 0;j < K;j++)
		{
			if(a[i].score[j]>=0)
				temptotal+=a[i].score[j];
		}
		a[i].total = temptotal;
	}
	sort(a,a+N,cmp);
	a[0].rank = 1;
	for(int i = 1;i < N;i++)
	{
		if(a[i].total != a[i - 1].total)
			a[i].rank = i + 1;
		else
			a[i].rank = a[i - 1].rank;
	}
	for(int i = 0;i < N;i++)
	{
		if(a[i].flag == 1)
		{
			printf("%d %05d %d ",a[i].rank,a[i].ID,a[i].total);
			for(int j = 0;j < K;j++)
			{
				if(a[i].score[j] == -1)
				{
					printf("0");
				}
				else if(a[i].score[j]!=-2)
				{
					printf("%d",a[i].score[j]);
				}
				else
					printf("-");
				if(j!=K-1)
					putchar(' ');
			}
			if(i!=N-1)
				putchar('\n');
		}
	}
	return 0;
}

要点:

  1. 如果考生某题已经获得满分,若输入仍为该题且为满分,注意此时该同学答题为perfect的题目不能加1,否则第5个测试点不通过。
  2. 输出格式需注意每一行最后无多余空格,否则格式错误。
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 13
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 13
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值