POJ 3261 Milk Patterns

Description

Farmer John has noticed that the qualityof milk given by his cows varies from day to day. On further investigation, hediscovered that although he can't predict the quality of milk from one day tothe next, there are some regular patterns in the daily milk quality.

To perform a rigorous study, he hasinvented a complex classification scheme by which each milk sample is recordedas an integer between 0 and 1,000,000 inclusive, and has recorded data from asingle cow over N (1 ≤N ≤ 20,000) days. Hewishes to find the longest pattern of samples which repeats identically atleast K (2 ≤ K  N) times. This mayinclude overlapping patterns -- 1 2 3 2 3 2 3 1 repeats 2 3 2 3 twice, forexample.

Help Farmer John by finding the longestrepeating subsequence in the sequence of samples. It is guaranteed that atleast one subsequence is repeated at least K times.

Input

Line 1: Twospace-separated integers: N and K 
Lines 2..N+1:
 N integers, one perline, the quality of the milk on day i appears on the ith line.

Output

Line 1: Oneinteger, the length of the longest pattern which occurs at least K times

Sample Input

8 2

1

2

3

2

3

2

3

1

Sample Output

4

题目大意:求一个含有N个数字的串中,至少出现了K次的子串的最大长度。

 

先用后缀数组求出height值,接着问题就可以转化成,height数组中连续k-1个中的最小值的最大值。

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<deque>
#include<algorithm>
#define MAX 1000010
using namespace std;

int n ,k ,num[MAX];
int wa[MAX] ,wb[MAX] ,wv[MAX] ,ws1[MAX] ,sa[MAX];
int rank1[MAX],height[MAX];

int cmp(int *r,int a,int b,int l)
{
	return r[a]==r[b]&&r[a+l]==r[b+l];
}

void da(int *r,int *sa,int n,int m)
{
	int i,j,p,*x=wa,*y=wb,*t;
	for(i=0;i<m;i++) ws1[i]=0;
	for(i=0;i<n;i++) ws1[x[i]=r[i]]++;
	for(i=1;i<m;i++) ws1[i]+=ws1[i-1];
	for(i=n-1;i>=0;i--) sa[--ws1[x[i]]]=i;
	for(j=1,p=1;p<n;j*=2,m=p)
	{
		for(p=0,i=n-j;i<n;i++) y[p++]=i;
		for(i=0;i<n;i++) if(sa[i]>=j) y[p++]=sa[i]-j;
		for(i=0;i<n;i++) wv[i]=x[y[i]];
		for(i=0;i<m;i++) ws1[i]=0;
		for(i=0;i<n;i++) ws1[wv[i]]++;
		for(i=1;i<m;i++) ws1[i]+=ws1[i-1];
		for(i=n-1;i>=0;i--) sa[--ws1[wv[i]]]=y[i];
		for(t=x,x=y,y=t,p=1,x[sa[0]]=0,i=1;i<n;i++)
			x[sa[i]]=cmp(y,sa[i-1],sa[i],j)?p-1:p++;
	}
	return;
}

void calheight(int *r,int *sa,int n)
{
	int i,j,k=0;
	for(i=1;i<=n;i++) 
		rank1[sa[i]]=i;
	for(i=0;i<n;height[rank1[i++]]=k)
		for(k?k--:0,j=sa[rank1[i]-1];r[i+k]==r[j+k];k++);
	return;
}
int main()
{
	while(~scanf("%d%d",&n,&k))
	{
		for(int i = 0;i < n;i++)
		{
			scanf("%d",&num[i]);
		}
		num[n] = 0;
		//求height值
		da(num,sa,n+1,1000001);
		calheight(num,sa,n);
		//求height中连续k个的最小值的最大值
		deque<int> q;
		int ans = 0;
		for(int i = 1;i <= n;i++)
		{
			while(!q.empty()&&height[i] <= height[q.back()])
			{
				q.pop_back();
			}
			while(!q.empty()&&q.front() <= i - k + 1)
			{
				q.pop_front();
			}
			q.push_back(i);
			if(i + 1 >= k && height[q.front()] > ans)
			{
				ans = height[q.front()];
			}
		}

		printf("%d\n",ans);
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值