ReactNative异常: java.lang.UnsatisfiedLinkError: could find DSO to load: libreactnativejni.so

异常:

Caused by: java.lang.UnsatisfiedLinkError: could find DSO to load: libreactnativejni.so             
	 at com.facebook.soloader.SoLoader.loadLibraryBySoName(SoLoader.java:213) 
解决:

在app的build.gradle中添加:


 defaultConfig {
        applicationId "com.example.lipiao.myreactnativeapp"
        minSdkVersion 16
        targetSdkVersion 25
        versionCode 1
        versionName "1.0"
        ndk{
            abiFilters "armeabi-v7a","x86"
        }
    }
    packagingOptions {
        exclude "lib/arm64-v8a/librealm-jni.so"
    }


  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值