(PKU_ACM)Japan

 

Description
Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.

Input
The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the East coast and second one is the number of the city of the West coast.

Output
For each test case write one line on the standard output:
Test case (case number): (number of crossings)

Sample Input

 1
3 4 4
1 4
2 3
3 2
3 1

Sample Output

Test case 1: 5
//第一次正式用wps写了个解题报告,不过好像自己都看不下去。
//解题报告估计可以用惨不忍睹来形容,让同学看了一下,他说看不懂,唉。
//无语,居然附件连wps都不能上传。
//把源程序上传一下算了吧,看不看得懂,自求多福了。
 
/*************************************************************************
	2007-10-5
	From acm.pku.cn
**************************************************************************/
#include<stdio.h>
#include <string.h>
#define Max 1010
_int64 temp[Max];       
int a[Max][Max];       /*保存交点的数组*/
int main()
{
    long i, j, k, T, N, M, sum;
 int x, y;
    long K;
    _int64 count;       /*保存交点数*/
    scanf("%ld", &T);
    for(i = 0; i < T; i++)
    {
        scanf("%ld %ld", &N, &M);
  memset(a, 0, sizeof(a));  
  memset(temp, 0, sizeof(temp));
        scanf("%ld", &K);
        for(j = 0; j < K; j++)
        {
   scanf("%d %d", &x, &y);
   a[x][y] = 1;
  }
  count = 0;
  temp[M] = 0;       /*以下代码参考ReadMe.wps*/
  for(j = M-1; j >=1; j--)
    temp[j] = temp[j+1] + a[1][j+1];
        for(j = 2; j < N; j++)
        {
   sum = 0;
            for(k = M; k >= 1; k--)
            {
    if(a[j][k] == 1)
    {
     count += temp[k];
     count -= sum;
    }
    sum += a[j][k];
    if(k > 1)
     temp[k-1] += sum;
            }
        }
  for(j = 1; j < M; j++)
   if(a[N][j] == 1)
    count += temp[j];
        printf("%Test case %d: %I64d/n", i+1, count);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值