2016多校训练Contest7: 1002 Hearthstone hdu5810

Problem Description
Mr. Chopsticks is interested in random phenomena, and he conducts an experiment to study randomness. In the experiment, he throws n balls into m boxes in such a manner that each ball has equal probability of going to each boxes. After the experiment, he calculated the statistical variance V as
V=mi=1(XiX¯)2m

where  Xi  is the number of balls in the ith box, and  X¯  is the average number of balls in a box.
Your task is to find out the expected value of V.
 

Input
The input contains multiple test cases. Each case contains two integers n and m (1 <= n, m <= 1000 000 000) in a line.
The input is terminated by n = m = 0.
 

Output
For each case, output the result as A/B in a line, where A/B should be an irreducible fraction. Let B=1 if the result is an integer.
 

Sample Input
  
  
2 1 2 2 0 0
 

Sample Output
  
  
0/1 1/2
Hint
In the second sample, there are four possible outcomes, two outcomes with V = 0 and two outcomes with V = 1.

E[V]=E[mi=1m(XiX¯)2]=E[(XiX¯)2]=E[Xi22XiX¯+X¯2]

= E[X_i^2] - 2\bar XE[X_i] + E[\bar X^2] = E[X_i^2] - 2\bar X^2 + \bar X^2 = E[X_i^2] - \frac{n^2}{m^2}=E[Xi2]2X¯E[Xi]+E[X¯2]=E[Xi2]2X¯2+X¯2=E[Xi2]m2n2

所以关键是要求出E[X_i^2]E[Xi2]. 我们用随机变量Y_jYj来表示第j个球是否在第i个盒子中,如果在则Y_j = 1Yj=1,否则Y_j = 0Yj=0. 于是

E[X_i^2] = E[(\sum_{j=1}^{n} Y_j)^2] = E[\sum_{j=1}^{n} Y_j^2] + 2E[\sum_{j=1}^{n} \sum_{k=1,k\neq j}^{n} Y_jY_k] = nE[Y_j^2] + n(n-1)E[Y_jY_k]E[Xi2]=E[(j=1nYj)2]=E[j=1nYj2]+2E[j=1nk=1,kjnYjYk]=nE[Yj2]+n(n1)E[YjYk]

=\frac{n}{m}+\frac{n(n-1)}{m^2}=mn+m2n(n1)

因此,

E[V] = \frac{n}{m} + \frac{n(n-1)}{m^2} - \frac{n^2}{m^2} = \frac{n(m-1)}{m^2}E[V]=mn+m2n(n1)m2n2=m2n(m1)


官方题解如上。。因为是队友推的我具体不太清楚。。

#include <stdio.h>
#include <algorithm>
using namespace std;
typedef __int64 ll;
ll gcd(ll n,ll m){
    ll r;
    while(m){
        r = n%m;
        n = m;
        m = r;
    }
    return n;
}

int main(void){
    ll a,b;
    ll n,m;
    while(scanf("%I64d%I64d",&n,&m)!=EOF){
        if(n==0&&m==0){
            break;
        }
        a = n*(m-1);
        b = m*m;
        ll g = gcd(a,b);
        printf("%I64d/%I64d\n",a/g,b/g);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值