hdu 5948 Thickest Burger 2016ACM/ICPC沈阳赛区现场赛A

Problem Description
ACM ICPC is launching a thick burger. The thickness (or the height) of a piece of club steak is A (1 ≤ A ≤ 100). The thickness (or the height) of a piece of chicken steak is B (1 ≤ B ≤ 100). 
The chef allows to add just three pieces of meat into the burger and he does not allow to add three pieces of same type of meat. As a customer and a foodie, you want to know the maximum total thickness of a burger which you can get from the chef. Here we ignore the thickness of breads, vegetables and other seasonings.
 

Input
The first line is the number of test cases. For each test case, a line contains two positive integers A and B.
 

Output
For each test case, output a line containing the maximum total thickness of a burger.
 

Sample Input
  
  
10 68 42 1 35 25 70 59 79 65 63 46 6 28 82 92 62 43 96 37 28
 

Sample Output
  
  
178 71 165 217 193 98 192 246 235 102
Hint
Consider the first test case, since 68+68+42 is bigger than 68+42+42 the answer should be 68+68+42 = 178. Similarly since 1+35+35 is bigger than 1+1+35, the answer of the second test case should be 1+35+35 = 71.

a,b中大数*2+小数即可

#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
using namespace std;
int main()
{
	int T;
	scanf("%d",&T);
	while(T>0)
	{
		T--;
		int x,y;
		scanf("%d%d",&x,&y);
		if(x>y)
			printf("%d\n",x+x+y);
		else
			printf("%d\n",x+y+y);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值