hdu 5950 Recursive sequence 2016ACM/ICPC沈阳赛区现场赛C

Problem Description
Farmer John likes to play mathematics games with his N cows. Recently, they are attracted by recursive sequences. In each turn, the cows would stand in a line, while John writes two positive numbers a and b on a blackboard. And then, the cows would say their identity number one by one. The first cow says the first number a and the second says the second number b. After that, the i-th cow says the sum of twice the (i-2)-th number, the (i-1)-th number, and  i4 . Now, you need to write a program to calculate the number of the N-th cow in order to check if John’s cows can make it right. 
 

Input
The first line of input contains an integer t, the number of test cases. t test cases follow.
Each case contains only one line with three numbers N, a and b where N,a,b <  231  as described above.
 

Output
For each test case, output the number of the N-th cow. This number might be very large, so you need to output it modulo 2147493647.
 

Sample Input
  
  
2 3 1 2 4 1 10
 

Sample Output
  
  
85 369
Hint
In the first case, the third number is 85 = 2*1十2十3^4. In the second case, the third number is 93 = 2*1十1*10十3^4 and the fourth number is 369 = 2 * 10 十 93 十 4^4.


这是一个和前面两项相关的转移式,我们可以考虑用矩阵维护

但是有个i^4,考虑将i^4转移为(i+1)^4,用二项式定理展开,(i+1)^4=i^4+4i^3+6i^2+4i+1

那么分别再维护i^3 i^2 i和1即可,转移同理

最终的转移矩阵为

0 2 0 0 0 0 0

1 1 0 0 0 0 0

0 1 1 0 0 0 0

0 0 4 1 0 0 0

0 0 6 3 1 0 0

0 0 4 3 2 1 0

0 0 1 1 1 1 1

直接上矩阵快速幂即可

#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
using namespace std;
const int N=15;
long long MOD=2147493647ll;
struct Matrix
{
	long long grid[N][N];
	int row,col;
	Matrix():row(N),col(N)
	{
    	memset(grid, 0, sizeof grid);
  	}
  	Matrix(int row, int col):row(row),col(col)
	{
    	memset(grid, 0, sizeof grid);
  	}
  	Matrix operator *(const Matrix &b)
	{
    	Matrix res(row, b.col);
    	for(int i = 0; i<res.row; i++)
      		for(int j = 0; j<res.col; j++)
        		for(int k = 0;k<col; k++)
        			res[i][j] = (res[i][j] + grid[i][k] * b.grid[k][j]) % MOD;
  		return res;
 	}
 	Matrix operator ^(long long exp)
	{
    	Matrix res(row, col);
    	for(int i = 0; i < row; i++)
			res[i][i] = 1;
    	Matrix temp = *this;
    	for(; exp > 0; exp >>= 1, temp = temp * temp)
      		if(exp & 1) res = temp * res;
    	return res;
  	}
  	long long* operator[](int index)
	{
    	return grid[index];
  	}
 	void print()
	{
    	for(int i = 0; i <row; i++)
		{
      		for(int j = 0; j < col-1; j++)
        		printf("%d ",grid[i][j]);
      		printf("%d\n",grid[i][col-1]);
    	}
	}
};
int main()
{
	int T;
	scanf("%d",&T);
	while(T>0)
	{
		T--;
		long long n,a,b;
		scanf("%lld%lld%lld",&n,&a,&b);
		Matrix xt(7,7);
		xt[0][1]=2;
		xt[1][0]=xt[1][1]=xt[6][2]=1;
		xt[2][1]=xt[2][2]=1;
		xt[3][2]=xt[5][2]=4;
		xt[4][2]=6;
		xt[3][3]=xt[6][3]=1;
		xt[4][3]=xt[5][3]=3;
		xt[4][4]=xt[6][4]=1;
		xt[5][4]=2;
		xt[5][5]=xt[6][5]=xt[6][6]=1;
		xt=xt^(n-2);
	//	xt.print();
		long long ans=(xt[0][1]*a%MOD+xt[1][1]*b%MOD+xt[2][1]*81ll%MOD+xt[3][1]*27ll%MOD+xt[4][1]*9ll%MOD+xt[5][1]*3ll%MOD+xt[6][1])%MOD;
		printf("%lld\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值