Sum It Up

Sum It Up

Problem Description
Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t=4, n=6, and the list is [4,3,2,2,1,1], then there are four different sums that equal 4: 4,3+1,2+2, and 2+1+1.(A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.

Input
The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x1,…,xn. If n=0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12(inclusive), and x1,…,xn will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.

Output
For each test case, first output a line containing ‘Sums of’, the total, and a colon. Then output each sum, one per line; if there are no sums, output the line ‘NONE’. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distince; the same sum connot appear twice.

Sample Input
4 6 4 3 2 2 1 1
5 3 2 1 1
400 12 50 50 50 50 50 50 25 25 25 25 25 25
0 0

Sample Output
Sums of 4:
4
3+1
2+2
2+1+1
Sums of 5:
NONE
Sums of 400:
50+50+50+50+50+50+25+25+25+25
50+50+50+50+50+25+25+25+25+25+25
分析:关键是怎么去重,就拿最后一组数据来说 在6个25中选择四个25,有c(6,4)中选择,而我们需要做的是只保留一组数据!
我再举一个例子:150 6 50 50 50 50 25 25后者对应数组 a[0] a[1] a[2] a[3] a[4] a[5]

  1. 第一次dfs找的是a[0]+a[1]+a[2]=150 满足条件 如果没有

    while(pos+1<n&&a[pos]==a[pos+1])
    pos++;//关键

    这段代码,下一次,找的是 a[0]+a[1]+a[2],注意递归返回的位置,然而 a[0]+a[1]+a[2]和a[0]+a[1]+a[2]都是 50 50 50 重复了 不符合题意 所以加上关键代码
    2.如果不加上去重的话 会变成这样:

这里写图片描述
3.最后是代码部分

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int num,n,pos;
int a[15],b[15];
bool judge=false;
void output(int depth)
{
    for(int i=0;i<depth;++i)
     if(i==0) printf("%d",b[i]);
     else
     printf("+%d",b[i]);
     printf("\n");
}
void dfs(int depth,int sum,int pos)
{
    if(sum==num)
    {
        judge=true;
        output(depth);
        return ;
    }
    if(sum>num) return;//超出了 终止递归
    if(pos>=n) return ;//选择的数的位置超出了数据范围
    b[depth]=a[pos];
    dfs(depth+1,sum+a[pos],pos+1);
    **while(pos+1<n&&a[pos]==a[pos+1])
    pos++;//关键**
    dfs(depth,sum,pos+1);
}
int main()
{
    while(scanf("%d %d",&num,&n)&&num){
        printf("Sums of %d:\n",num);
        for(int i=0;i<n;i++) scanf("%d",&a[i]);
        judge=false;
        dfs(0,0,0);
        if(judge==false) printf("NONE\n");
    }
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值