C - Sum It Up hdu1258

问题描述

Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t = 4, n = 6, and the list is [4, 3, 2, 2, 1, 1], then there are four different sums that equal 4: 4, 3+1, 2+2, and 2+1+1. (A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.



输入

The input file will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x 1 , . . . , x n . If n = 0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12 (inclusive), and x 1 , . . . , x n will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.



输出

For each test case, first output a line containing `Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line `NONE'. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distinct; the same sum cannot appear twice.



样例输入

4 6 4 3 2 2 1 1
5 3 2 1 1
400 12 50 50 50 50 50 50 25 25 25 25 25 25
0 0

样例输出

Sums of 4:
4
3+1
2+2
2+1+1
Sums of 5:
NONE
Sums of 400:
50+50+50+50+50+50+25+25+25+25

50+50+50+50+50+25+25+25+25+25+25



dfs,先对输入的数据从大到小排序,然后一层一层的看,如果遇到和前面的一样,则需要回溯去重;

代码如下:

###

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <stack>
#include <string.h>
#include <vector>
#include <queue>
#include <cmath>
#include <iomanip>
using namespace std;

int sum=0, t;bool mark=false;
int a[100+5];int b[100+5];

bool cmp(int i,int j)
{
    return i>j;
}


void dfs(int cur,int summ,int k)
{


    if(summ>sum)return ;
    if(summ==sum)
    {

        for(int i=1;i<k-1;i++)
            cout<<b[i]<<"+";
        cout<<b[k-1]<<endl;
        mark=true;
        return ;
     }

     for(int i=cur;i<=t;i++)
     {
         if(summ+a[i]>sum)continue;
         b[k]=a[i];
         dfs(i+1,summ+a[i],k+1);
         while(i<t&&a[i]==a[i+1])//去重;
            i++;
     }

}

int main()
{
    while(cin>>sum>>t)
    {
        mark=false;
        if(sum==0&&t==0)
            break;
            cout<<"Sums of "<<sum<<":"<<endl;
        memset(a,0,t);
        for(int i=1;i<=t;i++)
            scanf("%d",&a[i]);
        sort(a+1,a+t+1,cmp);//先从大到小排序;
        dfs(1,0,1);
        if(mark==false)
            cout<<"NONE"<<endl;
    }
}

###

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值