POJ 3278 Catch that cow

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.
Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

题目思路:

本题输入两个位置,分别代表农夫的位置和牛的位置,农夫有三种移动方式,可以向前走一步(x+1)或者向后走一步(x-1),或者向前走2倍当前位移(2x步),要找出农夫抓到牛的最短时间。(牛的位置不改变)。这是一个典型的广搜问题,搜索出最短的时间,如果农夫的坐标大于牛的坐标,那么农夫只能是向后一步一步的移动。

AC代码如下:


#include <iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
int sx,ex;
int n,k;
const int maxn=1e5+5;
int vis[maxn];
bool bfs()
{
	queue<int>que;
	sx=n;ex=k;
	que.push(sx);
	vis[sx]=1;
	while(!que.empty())
	{
		int x1=que.front();
		que.pop();
		if(x1-1<maxn&&x1-1>=0&&!vis[x1-1]){que.push(x1-1);vis[x1-1]=vis[x1]+1;}
		if(x1+1<maxn&&!vis[x1+1]){que.push(x1+1); vis[x1+1]=vis[x1]+1;}
		if(x1*2<maxn&&!vis[2*x1]){que.push(x1*2);vis[x1*2]=vis[x1]+1;}
		if(x1-1==ex||x1+1==ex||x1*2==ex)return true;		
	}
	
	return false;
}

int main()
{
   int time;
	while(cin>>n>>k)
	{
		memset(vis,0,sizeof(vis));		
		if(bfs())cout<<vis[k]-1<<endl;
	}
	
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值