杭电acm 1005 Number Sequence

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 116886    Accepted Submission(s): 28442


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
  
  
1 1 3 1 2 10 0 0 0
 

Sample Output
  
  
2 5
 

Author
CHEN, Shunbao
 
 首先要知道mod是求余运算,一开始没考虑那么多 ,直接迭代,结果超时! 仔细观察 对于这样的题目,通过第二个程序的打表代码不难发现肯定有输出规律,那么只需找出循环节即可,请参考大牛代码,我也学习了。


 

 

 

//一开始迭代 超时,通过打表可以看出循环
#include<iostream>
using namespace std;
int main()
{
 int A,B,n;
 int a,a1,a2;
 while(cin>>A>>B>>n,A+B+n)
 {
  a=0;a1=a2=1;
  for(int i=0;i<n-2;i++)
  {

   a=(A*a1+B*a2);
      a2=a1;
   a1=a;
  }
  cout<<a<<endl;
 }
 return 0;
}


AC代码:


#include<iostream>
using namespace std;
int f[100000005];
int main()
{
    int a,b,n,i,j;

    f[1]=1;f[2]=1;
    while(cin>>a>>b>>n,a+b+n)
    {
        int s=0;//记录周期
        
        for(i=3;i<=n;i++)
        {
            f[i]=(a*f[i-1]+b*f[i-2])%7;
            for(j=2;j<i;j++)
            if(f[i-1]==f[j-1]&&f[i]==f[j])//此题可以这样做的原因就是 2个确定后就可以决定后面的
            {
                s=i-j;
                //cout<<j<<" "<<s<<" >>"<<i<<endl;
                break;
            }
            if(s>0) break;//一开始s==0;如果找到循环节,即可跳出循环;
        }
        if(s>0){

                 f[n]=f[(n-j)%s+2];//对于每个出入的n,转换为一个循环节内的数并复制给所求;
                 //cout<<"f["<<n<<"]:="<<"f["<<(n-j)%s+j<<"] "<<endl;
               }
        cout<<f[n]<<endl;

    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值