哈理工校园编程练习赛杭电 acm 4432 G.Sum of divisors

Sum of divisors

 

TimeLimit: 2000/1000 MS(Java/Others)    Memory Limit:32768/32768 K (Java/Others)

ProblemDescription

mmmis learning division, she's so proud of herself that she canfigure out the sumof all the divisors of numbers no larger than 100 within oneday!
But her teacher said "What if I ask you to give not only the sum butthesquare-sums of all the divisors of numbers within hexadecimal number100?"mmm get stuck and she's asking for your help.
Attention, because mmm has misunderstood teacher's words, you have to solveaproblem that is a little bit different.
Here's the problem, given n, you are to calculate the square sums of thedigitsof all the divisors of n, under the base m.

 

 

Input

Multipletest cases, each test cases is one line with twointegers.
n and m.(n, m would be given in 10-based)
1≤n≤109
2≤m≤16
There are less then 10 test cases.

 

 

Output

Outputthe answer base m.

 

 

SampleInput

10 2

30 5

 

 

SampleOutput

110

112

Hint

 

Use A, B, C...... for 10, 11, 12......

Test case 1: divisors are 1, 2, 5,10which means 1, 10, 101, 1010 under base 2, the square sum of digits is

1^2+ (1^2 + 0^2) + (1^2 + 0^2 + 1^2)+.... = 6 = 110 under base 2.

 

这个题压根就没时间做 做也做不出来啊 可笨蛋了现在的我 丫的

#include<iostream>

#include<math.h>

usingnamespace std;

 

intn,m;

intbit[10000],cnt;

 

voidchange(int n,int base)

{

    cnt=0;

    if(n)

        {

        change(n/base,base);

               printf("%c",n%base>9?n%base+'A'-10:n%base+'0');

 

    }

}

 

intmain()

{

    while(cin>>n>>m)

        {

        int sum=0,i;

        int t=(int)sqrt(n*1.0);

        for(i=1;i<=t;i++)

            if(n%i==0)

                       {

                int tmp=i;

                while(tmp)

                               {

                    sum+=(tmp%m)*(tmp%m);

                    tmp/=m;

                }

                tmp=n/i;

                if(tmp==i)

                    continue;

                while(tmp)

                               {

                    sum+=(tmp%m)*(tmp%m);

                    tmp/=m;

                }

            }

        change(sum,m);

               cout<<endl;

      

    }

    return 0;

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值