杭电 HDU ACM 5186 zhx's submissions

zhx's submissions

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1892    Accepted Submission(s): 507


Problem Description
As one of the most powerful brushes, zhx submits a lot of code on many oj and most of them got AC.
One day, zhx wants to count how many submissions he made on n ojs. He knows that on the ith oj, he made ai submissions. And what you should do is to add them up.
To make the problem more complex, zhx gives you n Bbase numbers and you should also return a Bbase number to him.
What's more, zhx is so naive that he doesn't carry a number while adding. That means, his answer to 5+6 in 10base is 1 . And he also asked you to calculate in his way.
 

Input
Multiply test cases(less than 1000 ). Seek EOF as the end of the file.
For each test, there are two integers n and B separated by a space. ( 1n100 , 2B36 )
Then come n lines. In each line there is a Bbase number(may contain leading zeros). The digits are from 0 to 9 then from a to z (lowercase). The length of a number will not execeed 200.
 

Output
For each test case, output a single line indicating the answer in Bbase (no leading zero).
 

Sample Input
  
  
2 3 2 2 1 4 233 3 16 ab bc cd
 

Sample Output
  
  
1 233 14
 

Source
 
浪费了好几个小时 从理解题意,题目意思是b进制数相加,每位相加结果不进位。只保留sum mod b的结果,且保证最后结果没有前置0;可以采用倒叙相加。看了看网上的代码,
感觉写的还挺简单了!
#include<iostream>
#include<string.h>
using namespace std;
int main()
{
	int n,b ;char ls[250][250],gq[250][250];
	
	while(cin>>n>>b)
	{
		int len, L=-1;
	memset(ls,0,sizeof(ls));
	memset(gq,0,sizeof(gq));
		for(int i=0;i<n;i++)
		{
			scanf("%s",ls[i]);
			 len=strlen(ls[i]);
			if(len>L)
				L=len;
			for(int j=0;j<len;j++)
			{
				gq[i][len-1-j]=ls[i][j];
			}
		}
		int sum=0;int flag=0;
		for(int k=L-1;k>=0;k--)
		{
			sum=0;
			for(int m=0;m<n;m++)
			{
				if(gq[m][k]<='9'&&gq[m][k]>='0')
					sum+=gq[m][k]-48;
				else if(gq[m][k]>=65&&gq[m][k]<='z')
					sum+=gq[m][k]+10-'a';
			}
			
			sum%=b;
			if(sum>9)
			{
				printf("%c",sum-10+'a');
				flag=1;
			}
			else 
			{
				if(sum)
					flag=1;//注意只要在尚未发现第一个不为0得数之前都不能输出!!!不能有前置0!wa至少五次!
				if(flag)
					printf("%d",sum);
			}
		}
			if(!flag)
				cout<<0;
		
		cout<<endl;
		
	}
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值