杭电 HDU ACM 1412 {A} + {B}

{A} + {B}

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13969    Accepted Submission(s): 5798


Problem Description
给你两个集合,要求{A} + {B}.
注:同一个集合中不会有两个相同的元素.
 

Input
每组输入数据分为三行,第一行有两个数字n,m(0<n,m<=10000),分别表示集合A和集合B的元素个数.后两行分别表示集合A和集合B.每个元素为不超出int范围的整数,每个元素之间有一个空格隔开.
 

Output
针对每组数据输出一行数据,表示合并后的集合,要求从小到大输出,每个元素之间有一个空格隔开.
 

Sample Input
  
  
1 2 1 2 3 1 2 1 1 2
 

Sample Output
  
  
1 2 3 1 2
 

Author
xhd
 
#include<iostream>
#include<set>
using namespace std;
int main()
{
	int n1,n2,x;
	set<int>ls;
	while(cin>>n1>>n2)
	{
	for(int i=0;i<n1;i++)
	{
		cin>>x;
		ls.insert(x);
	}
	for(int j=0;j<n2;j++)
	{
		cin>>x;
		ls.insert(x);
	}
     int flag=1;
	for(set<int>::iterator it=ls.begin();it!=ls.end();it++)
	{
		if(flag)
		{
			cout<<*it;
			flag=0;
		}
		else
			cout<<" "<<*it;
	}
	cout<<endl;

	ls.clear();
	}
return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值