杭电 HDU ACM 1708 Fibonacci String



Fibonacci String

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4102    Accepted Submission(s): 1396


Problem Description
After little Jim learned Fibonacci Number in the class , he was very interest in it.
Now he is thinking about a new thing -- Fibonacci String .

He defines : str[n] = str[n-1] + str[n-2] ( n > 1 )

He is so crazying that if someone gives him two strings str[0] and str[1], he will calculate the str[2],str[3],str[4] , str[5]....

For example :
If str[0] = "ab"; str[1] = "bc";
he will get the result , str[2]="abbc", str[3]="bcabbc" , str[4]="abbcbcabbc" …………;

As the string is too long ,Jim can't write down all the strings in paper. So he just want to know how many times each letter appears in Kth Fibonacci String . Can you help him ?
 

Input
The first line contains a integer N which indicates the number of test cases.
Then N cases follow.
In each case,there are two strings str[0], str[1] and a integer K (0 <= K < 50) which are separated by a blank.
The string in the input will only contains less than 30 low-case letters.
 

Output
For each case,you should count how many times each letter appears in the Kth Fibonacci String and print out them in the format "X:N".
If you still have some questions, look the sample output carefully.
Please output a blank line after each test case.

To make the problem easier, you can assume the result will in the range of int.
 

Sample Input
  
  
1 ab bc 3
 

Sample Output
  
  
a:1 b:3 c:2 d:0 e:0 f:0 g:0 h:0 i:0 j:0 k:0 l:0 m:0 n:0 o:0 p:0 q:0 r:0 s:0 t:0 u:0 v:0 w:0 x:0 y:0 z:0
 

Author
linle
 

Source
 
一开始就是挺傻的 ,最后才发现必然超内存。数据量是超级大!参考网上代码,用到了映射 ,顺便也学习了下。解题思路是用三个map组  分别记录相邻的三个状态。并对每一次字符串叠加更新每个字母的状态!
开始的时候 错误代码,头脑太简单了。:
#include<iostream>
#include<string>
using namespace std;
int main()
{
	int n,k,ls[30];
	string str[51];
	cin>>n;
	while(n--)
	{
		for(int l=0;l<30;l++)
			ls[l]=0;
		
		cin>>str[0]>>str[1]>>k;
		for(int i=2;i<=k;i++)
			str[i]=str[i-2]+str[i-1];
	   for(int m=0;m<str[k].size();m++)
	   {
		   ls[str[k][m]-'a']++;
	   }
	   for(int t=0;t<26;t++)
	   {
		   cout<<char('a'+t)<<":"<<ls[t]<<endl;
	   }
	   cout<<endl;
	   
	 }
	return 0;
}


AC Code:
#include<iostream>
#include<map>
#include<string>
using namespace std;

int main()
{
	int n;
	cin>>n;
	while(n--)
	{
		map<char,int>ls1;
		map<char,int>ls2;
		map<char,int>ls3;
		string str0,str1;
		int k;
		cin>>str0>>str1>>k;
		if(k==0)
		{
			for(int i=0;i<str0.size();i++)
				ls1[str0[i]]++;
			for( int g='a';g<='z';g++)
				cout<<char(g)<<":"<<ls1[g]<<endl;
		}
		else if(k==1)
		{
			for(int m=0;m<str1.size();m++)
				ls2[str1[m]]++;
			for(int k='a';k<='z';k++)
				cout<<char(k)<<":"<<ls2[k]<<endl;
		}
		else
		{
			for(int q=0;q<str0.size();q++)
				ls1[str0[q]]++;
			for(int v=0;v<str1.size();v++)
				ls2[str1[v]]++;

			while(--k)
			{
				for(int p=97;p<=122;p++)
				{
					ls3[p]=ls2[p]+ls1[p];
					ls1[p]=ls2[p];
					ls2[p]=ls3[p];
				
				}
			}
				for(int M=97;M<123;M++)
					cout<<char(M)<<":"<<ls3[M]<<endl;
			
		}
		cout<<endl;
		
	}
	return 0;
}




又看了看,发现了一个写的比上个思路更加简洁的。来自:


用了个二维数组。
请看:
#include<stdio.h>
#include<string.h>
int ans[50][27];             
int main()
{
 int T,n,i,j;
 char s1[31],s2[31];
 scanf("%d",&T);
 while(T--)
 {
  scanf("%s%s%d",s1,s2,&n);
  memset(ans,0,sizeof(ans));
  for(i=0;s1[i]!=NULL;i++)
     ans[0][s1[i]-'a']++;
        for(i=0;s2[i]!=NULL;i++)
     ans[1][s2[i]-'a']++;
        for(i=2;i<=n;i++)
     for(j=0;j<26;j++)
             ans[i][j]=ans[i-1][j]+ans[i-2][j];
        for(i=0;i<26;i++)
           printf("%c:%d\n",'a'+i,ans[n][i]);
        printf("\n"); 
 }
 return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值