Eddy's picture
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 7800 Accepted Submission(s): 3956
Problem Description
Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends 's view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.
Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length which the ink draws?
Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length which the ink draws?
Input
The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point.
Input contains multiple test cases. Process to the end of file.
Input contains multiple test cases. Process to the end of file.
Output
Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points.
Sample Input
3 1.0 1.0 2.0 2.0 2.0 4.0
Sample Output
3.41
Author
eddy
复习一下最短路。观察他的点的给出形式。计算出每个点之间的距离,那么可以用一个矩阵表示,用双重for循环构造矩阵。用结构体存储点的属性。
1a完事儿,大晚上的。
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<cmath>
const int INF=103;
double G[INF][INF];
int vis[INF];
double low[INF];
double res,n;
using namespace std;
struct Edge
{
double x,y;
} per[INF];
double cacu(double x1,double y1,double x2,double y2)
{
return sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
}
double prim()
{
res=0;
memset(vis,0,sizeof(vis));
vis[0]=1;
for(int i=1; i<n; i++)
low[i]=G[0][i];
for(int i=1; i<n; i++)
{
double MIN=0x1f1f1f1f;
int loc;
for(int j=0; j<n; j++)
{
if(!vis[j]&&MIN>low[j])
{
MIN=low[j];
loc=j;
}
}
res+=MIN;
vis[loc]=1;
for(int k=0; k<n; k++)
{
if(!vis[k]&&low[k]>G[loc][k])
{
low[k]=G[loc][k];
}
}
}
return res;
}
int main()
{
while(cin>>n)
{
for(int i=0; i<n; i++)
{
cin>>per[i].x>>per[i].y;
}
for(int i=0; i<n; i++)
{
for(int j=0; j<n; j++)
{
G[i][j]=cacu(per[i].x,per[i].y,per[j].x,per[j].y);
}
}
printf("%.2lf\n",prim());
}
return 0;
}