poj 3928 Ping pong(树状数组)

Ping pong
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1352 Accepted: 509

Description

N(3<=N<=20000) ping pong players live along a west-east street(consider the street as a line segment). Each player has a unique skill rank. To improve their skill rank, they often compete with each other. If two players want to compete, they must choose a referee among other ping pong players and hold the game in the referee's house. For some reason, the contestants can't choose a referee whose skill rank is higher or lower than both of theirs. The contestants have to walk to the referee's house, and because they are lazy, they want to make their total walking distance no more than the distance between their houses. Of course all players live in different houses and the position of their houses are all different. If the referee or any of the two contestants is different, we call two games different. Now is the problem: how many different games can be held in this ping pong street?

Input

The first line of the input contains an integer T(1<=T<=20), indicating the number of test cases, followed by T lines each of which describes a test case. 
Every test case consists of N + 1 integers. The first integer is N, the number of players. Then N distinct integers a1, a2 ... aN follow, indicating the skill rank of each player, in the order of west to east. (1 <= ai <= 100000, i = 1 ... N).

Output

For each test case, output a single line contains an integer, the total number of different games. 

Sample Input

1 
3 1 2 3

Sample Output

1

<span style="font-size:18px;"><strong>首先按照等级值排序 ,那么接下来把研究问题集中到 对下标的研究,根据题目要求可以枚举排序后的每一个点找一找位置比它小的 ,和比他大的,
然后两边结果相乘(乘法原理)。结果就是以此点作为裁判时,可以举行的比赛场数。sum(i)-1  为左边小于新插入的数的个数,i-sum(i)-1
为左边大于新插入的元素个数,per【i】.id-  1-(sum(i)-1)为此点右边元素下标小于此点的个数。n-(  i-sum(i)-1)-per【i】.id为
右边元素下标大于此点下标的个数。 过程中保证了等级值一定位于每个元素枚举时的两边。</strong></span>
<pre name="code" class="cpp">#include<iostream>
#include<sstream>
#include<algorithm>
#include<cstdio>
#include<string.h>
#include<cctype>
#include<string>
#include<cmath>
#include<vector>
#include<stack>
#include<queue>
#include<map>
#include<set>
using namespace std;

const int INF=200003;
int cnt[INF];

struct A
{
    int v,id;


} per[INF];

bool cmp1(A a,A b)
{
    return  a.v<b.v;
}
bool cmp2 ( A a, A b)
{
    return a.v>b.v;
}
int lowbit(int x)
{
    return x&(-x);
}

void add(int x,int val)
{
    while(x<INF)
    {
        cnt[x]+=val;
        x+=lowbit(x);
    }
}

int sum(int x)
{
    int s=0;
    while(x>0)
    {
        s+=cnt[x];
        x-=lowbit(x);
    }
    return s;
}
int main()
{
    int t,n;
    cin>>t;
    while(t--)
    {
        cin>>n;
        memset(cnt,0,sizeof(cnt));
        long long  ans=0;
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&per[i].v);
            per[i].id=i;
        }
        sort(per+1,per+n+1,cmp1);
        for(int i=1; i<=n; i++)
        {
            add(per[i].id,1);
            long long  Lmin=sum(per[i].id)-1;
            long long  Lmax=i-Lmin-1;
            ans+=(  n-Lmax-per[i].id)*Lmin+Lmax*(per[i].id-Lmin-1);
        }
        cout<<ans<<endl;
    }
    return 0;
}



                
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值