HLG 哈理工 1053 Warcraft III (完全背包)

Warcraft III
Time Limit: 10000 MSMemory Limit: 65536 K
Total Submit: 587(194 users)Total Accepted: 260(173 users)Rating:Special Judge: No
Description

dccmx likes playing Warcraft III. Now, he is teaching his girlfriend to play it. In Warcraft III, there are many kinds of units. Every unit costs some gold and lumber. Different units have different attack value.

Now question comes. Given some amount of gold and a list of types of units, how to arrange your units to maximize the attack value of your units. Assume you have infinite lumbers.

Input

Line 1 contains an integer T: the number of test cases.

Next T blocks, each starts with two integers: G and U, represents the amount of gold and number of unit type. Next U lines, each contains two integers: the attack value of a type of unit and the cost.

Output

For each test case, output the maximum total attack value in one line.

Sample Input

2

100 1

20 10

300 4

100 60

250 120

120 100

35 20

Sample Output

200

605

Author

dccmx


/*=============================================================================
#
#      Author: liangshu - cbam 
#
#      QQ : 756029571 
#
#      School : 哈尔滨理工大学 
#
#      Last modified: 2015-08-29 00:24
#
#     Filename: C.cpp
#
#     Description: 
#        The people who are crazy enough to think they can change the world, are the ones who do ! 
=============================================================================*/
#
#include<stdio.h>
#include<iostream>
using namespace std;

const int INF = 100000;
int dp[INF];
struct A
{
    int val,cost;
}E[INF];
int main(){
    int T;
    cin>>T;
    while(T--){
        int G, U;scanf("%d%d",&G, &U);
        memset(dp, 0, sizeof(dp));
        for(int i = 1; i <= U; i++){
            scanf("%d%d",&E[i].val, &E[i].cost);
        }
        for(int i = 1; i <= U; i++){
            for(int j = E[i].cost; j <= G; j++){
                dp[j] = max(dp[j], dp[j - E[i].cost] + E[i].val);
            }
        }
     printf("%d\n",dp[G]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值