N!

Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!

Input

One N in one line, process to the end of file.

Output

For each N, output N! in one line.

Sample Input

1
2
3

Sample Output

1
2
6

代码

import java.math.*;
import java.util.*;

public class Test {

    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        while(sc.hasNextBigInteger()){
            int n=sc.nextInt();
            System.out.println(getSum(n));
        }

    }
    public static BigInteger getSum(int n){
        if(n==0||n==1)
        {
            return BigInteger.valueOf(1);
        }
        for(int i=2;i<=n;i++)
        {
            return BigInteger.valueOf(n).multiply(getSum(n-1));
        }
        return null;
    }
}

。multiply(乘)。
BigInteger 可以用来解决数据的溢出问题。
BigInteger方法总结
https://www.cnblogs.com/qingtianxt/p/5957013.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值