输出+—|方框

Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Give you the width and height of the rectangle,darw it.
 

Input

Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.
 

Output

For each case,you should draw a rectangle with the width and height giving in the input. 
after each case, you should a blank line.
 

Sample Input

       
       
3 2
 

Sample Output

       
       
+---+ | | | | +---+
 
解题思路:
输入nm,其实实际的字符是n+2,m+2.用一个二维数组,对每行每列讨论下,就行了。
但是要注意空格,换行。
代码:
#include<stdio.h>
#include<string.h>
int main()
{
int n,m,i,j;
char a[101][101];
while(scanf("%d%d",&n,&m)!=EOF)
{
   
  for(j=1;j<=n+2;j++)
  {
  if(j==1||j==n+2)
  {
  a[1][j]='+';
      a[m+2][j]='+';
}
 
  else
  {
  a[1][j]='-';
    a[m+2][j]='-';
}
 
}
for(i=1;i<=m+2;i++)
  {
  if(i==1||i==m+2)
  {a[i][1]='+';
  a[i][n+2]='+';
}
 
  else
  {a[i][1]='|';
  a[i][n+2]='|';
  }
}
  for(i=2;i<m+2;i++)
  {
  for(j=2;j<n+2;j++)
  {
  a[i][j]=' ';
  }
  }
 

for(i=1;i<=m+2;i++)
{
for(j=1;j<=n+2;j++)
 {
  printf("%c",a[i][j]);
 }
 printf("\n");
}
printf("\n");

return 0;
 } 
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值