Light-oj-1094 Farthest Nodes in a Tree (树的直径模板题)

Time Limit: 2000MSMemory Limit: 32768KB64bit IO Format: %lld & %llu


Description

Given a tree (a connected graph with no cycles), you have to find the farthest nodes in the tree. The edges of the tree are weighted and undirected. That means you have to find two nodes in the tree whose distance is maximum amongst all nodes.

Input

Input starts with an integer T (≤ 10), denoting the number of test cases.

Each case starts with an integer n (2 ≤ n ≤ 30000) denoting the total number of nodes in the tree. The nodes are numbered from 0 to n-1. Each of the next n-1 lines will contain three integers u v w (0 ≤ u, v < n, u ≠ v, 1 ≤ w ≤ 10000) denoting that node u and v are connected by an edge whose weight is w. You can assume that the input will form a valid tree.

Output

For each case, print the case number and the maximum distance.

Sample Input

2

4

0 1 20

1 2 30

2 3 50

5

0 2 20

2 1 10

0 3 29

0 4 50

Sample Output

Case 1: 100

Case 2: 80

AC代码:

#include <stdio.h> 
#include<string.h> 
#include<queue> 
#include <algorithm>   
#define MAX 30010   
using namespace std;  
struct Edge  
{  
    int from, to, val, next;  
}  edge[MAX*2];  //边的结构体,有正反两个方向,所以要*2; 
int head[MAX];    
int edgenum;      //边的数目;  
int dist[MAX];    //统计目前的最长路径; 
bool vis[MAX];    //标记统计过的点; 
int node, ans;  
int N;  
int k = 1;  
void init()  
{  
    edgenum = 0;  
    memset(head, -1, sizeof(head));  
}  
void addEdge(int u, int v, int w)  
{  
    edge[edgenum].from = u;
    edge[edgenum].to = v;
    edge[edgenum].val = w;
    edge[edgenum].next = head[u];
    head[u] = edgenum++;
}  
void BFS(int s) 
{
    memset(dist, 0, sizeof(dist));
	 memset(vis, false, sizeof(vis));
    queue<int> Q;
	 Q.push(s);
	 vis[s] = true;
	dist[s] = 0; 
	ans = 0;
    while(!Q.empty()) 
	{
        int u = Q.front();
		 Q.pop();
        for(int i = head[u]; i != -1; i = edge[i].next) 
		{
            int v = edge[i].to;
            if(!vis[v]) 
			{
                if(dist[v] < dist[u] + edge[i].val)
				 {
                    dist[v] = dist[u] + edge[i].val;
                }
                vis[v] = true;
                Q.push(v);
            }
        }
    }
    for(int i = 1; i<=N; i++) {
        if(ans < dist[i])
		 {
            ans = dist[i];
            node = i;
        }
    }
}
int main()  
{  
    int t;  
    scanf("%d", &t);  
    while(t--)  
    {  
	    init();
        scanf("%d", &N);  
        int a, b, c;  
        for(int i = 1; i < N; i++)  
        {  
            scanf("%d%d%d", &a, &b, &c);  
            a++, b++;  
            addEdge(a, b, c);  
            addEdge(b, a, c);  
        }  
		BFS(1);  
        BFS(node);  
        printf("Case %d: ", k++);  
        printf("%d\n", ans);  
    }
    return 0;  
}  


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值